[fdo-dev] Naming convention for RDBMS UnitTest

Dan Stoica dan.stoica at autodesk.com
Mon Aug 28 09:44:27 EDT 2006

Mateusz, go with 3. T* pMyObject. 


-----Original Message-----
From: Mateusz Loskot [mailto:mateusz at loskot.net] 
Sent: Sunday, August 27, 2006 9:20 PM
To: dev at fdo.osgeo.org
Subject: [fdo-dev] Naming convention for RDBMS UnitTest


What's the recommended naming convention of variables/objects
to use in the RDBMS UnitTest package?

I see 3 styles for pointers:
1. T* MyObject
2. T* myObject
3. T* pMyObject

Which one to use?

There are also different coding styles used in scope of single file,
in UT. Does it mean the coding style is not important here and I'm also
free to use my own coding style? It's a trivia, but I'd like to know
before I start implementing UTs for PostGIS, to avoid fixing it in

Mateusz Loskot

To unsubscribe, e-mail: dev-unsubscribe at fdo.osgeo.org
For additional commands, e-mail: dev-help at fdo.osgeo.org

More information about the Fdo-internals mailing list