[fdo-dev] Naming convention for RDBMS UnitTest
mateusz at loskot.net
Mon Aug 28 12:03:30 EDT 2006
Greg Boone wrote:
> Hi Mateusz,
> There is no absolute guideline for naming local function variables. You
> will find all 3 used and code reviews have not been looking explicitly
> for this issue. You are correct that option 3 is not heavily used. I and
> many others have been using option 2. Since this is not a big issue, I
> would recommend sticking with what you already have implemented and
> moving forward.
For me it's not a small issue because I have to read every line of
FDORDBMS code that will play with my FDO PostGIS driver.
So, it's helpful when I can see for a toke and know what's this.
FdoUpdateTest::MainFdoUpdateTest (FdoIConnection* Conn)
here, inside this function, Conn is named as a type (upper-case)
and yesterday, first I started to grep for the class definition,
before I did get up to this function prototype and learned
that it's a pointer.
I also prefer option 2., so I'll use it.
More information about the Fdo-internals