[fdo-dev] Naming convention for RDBMS UnitTest

Dan Stoica dan.stoica at autodesk.com
Mon Aug 28 13:05:17 EDT 2006

I (along with other people) will stick with my preference that 3) is
better because it is adding valuable information. e.g. in Ptr.h:

    bool CopyTo(T** ppT) throw()
Same rationale apply to local function variables.


-----Original Message-----
From: Mateusz Loskot [mailto:mateusz at loskot.net] 
Sent: Monday, August 28, 2006 12:04 PM
To: dev at fdo.osgeo.org
Subject: Re: [fdo-dev] Naming convention for RDBMS UnitTest

Greg Boone wrote:
> Hi Mateusz,
> There is no absolute guideline for naming local function variables.
> will find all 3 used and code reviews have not been looking explicitly
> for this issue. You are correct that option 3 is not heavily used. I
> many others have been using option 2. Since this is not a big issue, I
> would recommend sticking with what you already have implemented and
> moving forward.

For me it's not a small issue because I have to read every line of
FDORDBMS code that will play with my FDO PostGIS driver.
So, it's helpful when I can see for a toke and know what's this.
For example:
FdoUpdateTest::MainFdoUpdateTest (FdoIConnection* Conn)

here, inside this function, Conn is named as a type (upper-case)
and yesterday, first I started to grep for the class definition,
before I did get up to this function prototype and learned
that it's a pointer.

I also prefer option 2., so I'll use it.

Mateusz Loskot

To unsubscribe, e-mail: dev-unsubscribe at fdo.osgeo.org
For additional commands, e-mail: dev-help at fdo.osgeo.org

More information about the Fdo-internals mailing list