[fdo-users] Spatial Query with MySQL FDO provider

Gavin Cramer gavin.cramer at autodesk.com
Fri Feb 16 16:07:47 EST 2007

I just tried it by quickly hacking a unit test, and both the POINT and
LINESTRING examples worked for me.  I am using MySQL 5.0.24a.

However, I did notice that when I misspelled the property name (it was
supposed to be "Geometry" for the unit test), the resulting error
message was from MySQL, regarding a bad ')'.  It was not a complaint
about the column name, nor was it an FDO SQL translation exception about
a property name that you might expect if you created the filter using
C++ objects, e.g. with FdoSpatialCondition::Create().

Is this any help?


-----Original Message-----
From: fdo-users-bounces at lists.osgeo.org
[mailto:fdo-users-bounces at lists.osgeo.org] On Behalf Of George McLean
Sent: Thursday, February 15, 2007 6:15 PM
To: fdo-users at lists.osgeo.org
Subject: [fdo-users] Spatial Query with MySQL FDO provider

I am having trouble writing spatial queries against MySQL 5.0.18 using 
the OSGeo.MySQL.3.2 provider

I pass the string 'geometry INTERSECTS GEOMFROMTEXT ('POINT XY (2536400 
481800)')' to the SetFilter method of an MgFeatureQueryOptions object. 
When I call selectFeatures from a feature service object, I get no

When I use the filter string 'geometry INTERSECTS GEOMFROMTEXT 
('LINESTRING XY (2536400 481800, 2536500 481900)')' I get the following 
error on selection:

An exception occurred in FDO component. String does not represent a 
valid filter.

As far as I can tell the query string is OK. I have the same problem 
with using POLYGON as the geometry as well. Only POINT seems to work. 
When I query the capabilities of the MySQL provider it appears to me 
that LINESTRING and POLYGON are supported.

Any suggestions?


George McLean
fdo-users mailing list
fdo-users at lists.osgeo.org

More information about the fdo-users mailing list