[fdo-users] ODBC provider gives error when used together with Informix

Ismael Cams mapguide2007 at gmail.com
Fri Jun 1 08:07:29 EDT 2007

Hello all,

it seems to be there is a problem with the ODBC provider when trying to
connect to an Informix database. The problem is related to the manner the
SQL statements are sent. When sniffing on the SQL statements that are coming
in on the database we get for example:

SELECT H."x", H."y" FROM "cmplx_xy" H

This is causing a syntax error in the Informix database. I have looked
somewhat in the code and noticed these quotes have been added to support the
Oracle database (in col_.c):

/ Oracle allows a dot '.' character in a column name if 
                // it is double-quoted during an SQL "create table" or
"alter table"
                // command.  E.g.:
                //     alter table table2 add ( "name.withdot"
                // This is actually used in Oracle system tables in some
                // non-default installations (see defect 654283).  It
                // with FDO's identifier rules.  Rather than reject the
                // schema or table, we'll just skip the offending column.

The Sybase seems to suffer the same problem as the Informix database (which
makes sense as they are close connected to eachother), but for the Sybase
this has been managed in the code (no quotes are added in case of Sybase).

Because all my spatial data is stored in Informix this is really blocking
for me. Can it be solved without adapting the code and build the FDO myself
(I am not familiar with that stuff) ? Is there a chance it will be solved in
the near future in a release of the ODBC provider ?

Thanks in advance.
View this message in context: http://www.nabble.com/ODBC-provider-gives-error-when-used-together-with-Informix-tf3851905s18162.html#a10911634
Sent from the fdo-users mailing list archive at Nabble.com.

More information about the fdo-users mailing list