[fdo-users] libboost error on Ubuntu 8.04

Joanne Cook j.cook at oxfordarch.co.uk
Mon Jun 30 12:36:22 EDT 2008

Hi All,

I am trying to build mapguide open source (from subversion) on Ubuntu 8.04, following the tried and tested instructions for 7.10 from the wiki. However, I run into an error when running build_linux.sh in the fdo section. I *think* build_thirdparty went through OK. The log file for build_linux is huge (86MB), so I have just cut out the lines that seem to suggest there is a problem:

make[3]: Entering directory `/home/jo/fdosvn/Utilities/OWS'
make[3]: *** No rule to make target `/home/jo/fdosvn/Thirdparty/boost/stage/lib/libboost_thread-mt.a', needed by `libFdoOws.la'. Stop.
make[3]: Leaving directory `/home/jo/fdosvn/Utilities/OWS'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/jo/fdosvn/Utilities/OWS'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/jo/fdosvn/Utilities'
make: *** [all-recursive] Error 1

Then I seem to get the exact same error three more times about 50 lines apart. The whole build then continues until it gets to the King Oracle bit until it dies again, which I would expect because I don't have oracle.

So, I tried installing libboost-thread, but that didn't help. Is this a fatal error? Do you need more lines from the log? Is it a dead loss?

Many thanks


Joanne Cook
Senior IT Support and Development
Oxford Archaeology (North)
01524 880212

Files attached to this email may be in ISO 26300 format (OASIS Open Document Format). If you have difficulty opening them, please visit http://iso26300.info for more information.

More information about the fdo-users mailing list