[fdo-users] Problem building FDO 3.3 with MySQL/ODBC on CentOS 5

Andy Morsell amorsell at spatialgis.com
Fri Mar 14 15:24:40 EDT 2008

Hi Larry,
Thanks for the message.  Yes, I did not fully understand your post in the
MGOS list and I had previously compiled without MySQL/ODBC support without
any problems.  You're right, only when adding that to the mix did I
encounter the problem.

Your solution to edit the Makefile.am in the
/OpenSource_FDO/Providers/GenericRdbms/Src/UnitTest directory indeed solved
that problem.  Gavin's unixODBC clues also helped as I ran into a later
problem with libodbcinst.so not being found, but updating unixODBC-devel
solved that problem and I finally have an error free compilation.

Thank you both for your help!


larry white-2 wrote:
> Andy,
> This is the error I mentioned in a posting a few days ago.
> There are missing LD_LIBRARY references for 'libodbcinst' in the
> UnitTest Makefile.am
> You have to modify Makefile.am (and/or Makefile after initial
> compilation).
> In particular, in the 'UnitTestOdbc_LDADD' section you need to add a
> couple of lines (both may not be necessary, but it works).
> At (or around) line 154 and line 191, you'll find references to libodbc:
>  -lodbc \
> insert the additional following line
> -lodbcinst \
> Compilation should be successful after making that change; Unit Tests
> will run; and the provider will install and function properly (eg., I'm
> been using MySQL driver as the primary provider for some current
> testing. However, I have not used the ODBC provider.)
> -- larry white
> Sr Systems Analyst
> neomatix.ca
> Andy Morsell wrote:
>> I'm trying to build FDO 3.3 on CentOS 5.  I have been able to build with
>> the core providers without MySQL / ODBC support, but when I attempt to
>> build with that provider, it fails.  It fails in the same place when
>> using the FDO build_linux script with the --w rdbms switch, or when
>> using the build_linux script separately from the GenericRdbms
>> directory.  It does not fail if running the FDO build_linux script with
>> all default settings, but the FDO ODBC files are never created.  I do
>> have the MySQL client and developer libraries installed and correctly
>> referenced via the FDOMYSQL environment variable.  I also have the
>> unixodbc libraries installed.  Below is the last few lines of the
>> build.  Any insight on where to go next would be appreciated.  Thank you.
>> ../Rdbi/.libs/librdbi.a ../Util/.libs/libutil.a /usr/lib/libodbc.so -ldl
>> -lpthread -lz  -Wl,--rpath -Wl,/usr/local/fdo-3.3.0/lib
>> ../ODBC/.libs/libFdoRdbmsODBC.a(FdoRdbmsOdbcConnection.o): In function
>> `FdoRdbmsOdbcConnection::GetSchemaNameFromDsn()':
>> FdoRdbmsOdbcConnection.cpp:(.text+0x1c8f): undefined reference to
>> `SQLGetPrivateProfileString'
>> collect2: ld returned 1 exit status
>> make[3]: *** [UnitTestOdbc] Error 1
>> make[3]: Leaving directory
>> `/Software/FDO/OpenSource_FDO/Providers/GenericRdbms/Src/UnitTest'
>> make[2]: *** [all-recursive] Error 1
>> make[2]: Leaving directory
>> `/Software/FDO/OpenSource_FDO/Providers/GenericRdbms/Src/UnitTest'
>> make[1]: *** [all-recursive] Error 1
>> make[1]: Leaving directory
>> `/Software/FDO/OpenSource_FDO/Providers/GenericRdbms/Src'
>> make: *** [all-recursive] Error 1
>> Andy Morsell, P.E.
>> Spatial Integrators, Inc.
>> _http://www.SpatialGIS.com_
>> ------------------------------------------------------------------------
>> _______________________________________________
>> fdo-users mailing list
>> fdo-users at lists.osgeo.org
>> http://lists.osgeo.org/mailman/listinfo/fdo-users
> _______________________________________________
> fdo-users mailing list
> fdo-users at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/fdo-users

View this message in context: http://www.nabble.com/Problem-building-FDO-3.3-with-MySQL-ODBC-on-CentOS-5-tp16041144s18162p16051471.html
Sent from the fdo-users mailing list archive at Nabble.com.

More information about the fdo-users mailing list