[fdo-users] FDO Compile error (libxalan-c)

kernel_panic sudoaptgetinstalld00d3 at gmail.com
Wed Oct 21 13:07:03 EDT 2009


Since compiling mapguide trunk its just plainly IMPOSSIBLE (it wont
even compile build_oem :S) I tried what traian suggested (even with
all possible errors :p), regarding copying SFD and SHP files to the
path where mapguide looks for them

I actually did something a little different, because I didnt know
where mapguide looks for them, I put them in a "Inc" folder in
/usr/local/lib/fdo-3.5.0/Inc/" and changed any reference in the .h
files that pointed them somewhere else, to point to that same folder,
as well as changing the path where gwsfeaturequeryresults.cpp and
gwspreparedfeaturequery.cpp looked for them.

So... after doing that, I get this:

GwsPreparedFeatureQuery.cpp:73: error: cannot allocate an object of
abstract type 'CGwsFeatureIterator'
./inc/GwsQuery.h:682: note:   because the following virtual functions
are pure within 'CGwsFeatureIterator':
note:       virtual const FdoString*
note:       virtual FdoInt32 FdoIReader::GetPropertyIndex(const
note:      virtual FdoBoolean FdoIReader::GetBoolean(FdoInt32)
note:      virtual FdoByte FdoIReader::GetByte(FdoInt32)
note:      virtual FdoDateTime FdoIReader::GetDateTime(FdoInt32)
note:      virtual FdoDouble FdoIReader::GetDouble(FdoInt32)
note:      virtual FdoInt16 FdoIReader::GetInt16(FdoInt32)
note:      virtual FdoInt32 FdoIReader::GetInt32(FdoInt32)
note:      virtual FdoInt64 FdoIReader::GetInt64(FdoInt32)
note:      virtual FdoFloat FdoIReader::GetSingle(FdoInt32)
note:      virtual const FdoString* FdoIReader::GetString(FdoInt32)
note:      virtual FdoLOBValue* FdoIReader::GetLOB(FdoInt32)
note:      virtual FdoIStreamReader*
note:      virtual FdoBoolean FdoIReader::IsNull(FdoInt32)
note:       virtual FdoByteArray*
note:      virtual FdoIRaster* FdoIReader::GetRaster(FdoInt32)
note:       virtual const FdoByte*
FdoIFeatureReader::GetGeometry(FdoInt32, FdoInt32*)
note:       virtual FdoIFeatureReader*

Over and over again  :p

GwsPreparedFeatureQuery.cpp:75: error: cannot allocate an object of
abstract type 'CGwsSortMergeJoinQueryResults'

GwsPreparedFeatureQuery.cpp:77: error: cannot allocate an object of
abstract type 'CGwsNestedLoopsJoinQueryResults'

GwsPreparedFeatureQuery.cpp:79: error: cannot allocate an object of
abstract type 'CGwsNestedLoopSortedBlockJoinQueryResults'

GwsPreparedFeatureQuery.cpp:81: error: cannot allocate an object of
abstract type 'CGwsBatchSortedBlockJoinQueryResults'

GwsPreparedFeatureQuery.cpp:83: error: cannot allocate an object of
abstract type 'CGwsRightSortedJoinQueryResults'

GwsPreparedFeatureQuery.cpp:87: error: cannot allocate an object of
abstract type 'CGwsRightNestedLoopSortedBlockJoinQueryResults'

GwsPreparedFeatureQuery.cpp:89: error: cannot allocate an object of
abstract type 'CGwsRightBatchSortedBlockJoinQueryResults'

And finally:
make[4]: *** [GwsPreparedFeatureQuery.lo] Error 1
make[4]: se sale del directorio
make[3]: *** [all-recursive] Error 1
make[3]: se sale del directorio `/opt/mapguide-2.0.2/Server/src/Gws'
make[2]: *** [all-recursive] Error 1
make[2]: se sale del directorio `/opt/mapguide-2.0.2/Server/src'
make[1]: *** [all-recursive] Error 1
make[1]: se sale del directorio `/opt/mapguide-2.0.2/Server'
make: *** [all-recursive] Error 1

So :p:p Any ideas on how to solve this? :p (either this problem, or
the compile-from-trunk-being-herculean-task issue :p)

2009/10/16, kernel_panic <sudoaptgetinstalld00d3 at gmail.com>:
> Well, I decided to go from scratch, regarding MG from trunk, I deleted
> everything (from trunk) and started over again from zero.
> I downloaded everything again, and then I followed the instructions
> that I listed earlier, that were provided to my by the user
> "takashige"
> Now, after a while, I get an error close to the following. because the
> virtual machine where Im running this pretty much hangs up :p, if Im
> working from the GUI (Xserver) it crashes and I have to shift to
> another terminal to work, unable to get back to the GUI. The only way
> I can "proceed" is working straight from a terminal, from the
> beginning. It "hangs" when its starting to build everything in /src,
> but I cant see where, I think its after building Xquilla, after a
> while, it starts "working" again, but all it spews is constant
> "libtool line XXXX: you must specify a MODE: command not found" where
> XXXX are lines 6459 6460, with other errors as well:
> line 719: future versions of libtool will require mode=MODE be
> specified, command not found
> line 718: *** warning: inferring the mode of operation is deprecated:
> command not found
> line 751:  warning: cannot infer operation mode without MODE-ARGS:
> command not found
> Until it stops working, but whitout any "make error" message...
> If I run "build_oem.sh > file.txt" the last lines are:
> Making all in src
> make[1]: Entering directory `/opt/MgDev/Oem/CppUnit-1.9.14/src'
> Making all in cppunit
> make[2]: Entering directory `/opt/MgDev/Oem/CppUnit-1.9.14/src/cppunit'
> if /bin/sh ../../libtool --mode=compile g++-4.1 -DHAVE_CONFIG_H -I.
> -I. -I../../config -I../../include -I../../include    -g -O2 -MT
> AdditionalMessage.lo -MD -MP -MF ".deps/AdditionalMessage.Tpo" \
> 	  -c -o AdditionalMessage.lo `test -f 'AdditionalMessage.cpp' || echo
> './'`AdditionalMessage.cpp; \
> 	then mv -f ".deps/AdditionalMessage.Tpo" ".deps/AdditionalMessage.Plo"; \
> 	else rm -f ".deps/AdditionalMessage.Tpo"; exit 1; \
> 	fi
> make[2]: Leaving directory `/opt/MgDev/Oem/CppUnit-1.9.14/src/cppunit'
> make[1]: Leaving directory `/opt/MgDev/Oem/CppUnit-1.9.14/src'
> CPPUNIT 1.9.14: Error build failed (2).................
> Could it be related to the CPPUNIT issue ocurred by using the old
> cmake documentations procedure? (use internal cppunit).
> Anyways, the libtool error happen right after the previous message,

More information about the fdo-users mailing list