[fdo-users] Resource ID does not refer to a valid feature source

Heddo Klandermans h.klandermans at hawarIT.com
Fri Nov 19 03:48:35 EST 2010


Using MapGuide Studio 2010 I can make a succesful  connection to my 
database by FDO PostGIS connection (PostGreSQL 8.4 + PostGIS 3.4). Also 
(geometric) tables can be read to create layers.
After performing some changes in the database table structure the Data 
connection was still ok, but MG had problems in getting table-data for 
the layers. I fixed this by a Vacuum Analyse on the database and finally 
a reindex. This worked well and solved the problems.

After another change in my databse now data connection is still ok, but 
when trying to create a layer i get the message:
"Invalid Stream Header Exception" followed by "Resource ID does not 
refer to a valid feature source".

Any attempt to create a new folder and/or data connection in MG using 
FDOPostGIS connecting to that specific database gives the same problem: 
data connection is succesful, when creating a layer it displays these 
messages. Connecting to other databses does not give any problem.

I think this problem is caused by mismatch between Library settings and 
Database. Did anyone experience similar problems and if so what can be 
done to it?


ir. H.D. (Heddo) Klandermans
Senior Consultant

Hawar Information Technology bv
De Wymerts 7, 8701 WT Bolsward, NL
Postbus 42, 8700 AA Bolsward, NL
Tel.: (+31)-(0)515-570 333
E-mail: h.klandermans at HawarIT.com

More information about the fdo-users mailing list