[fdo-users] Resource ID does not refer to a valid feature source

Heddo Klandermans h.klandermans at hawarIT.com
Tue Nov 23 03:51:23 EST 2010

Thx for your reply. I will try this option out.
Another option might be to upgrade to MGStudio 2011. I will keep you 
informed about results.


Op 22-11-2010 18:49, Greg Boone schreef:
> The PostGIS 3.4 provider has not been tested heavily with MG, and has fallen off the active development list now that the PostgreSQL provider has been released. I know that there were a number of outstanding defects logged against the PostGIS provider that were never resolved. You might want to try the FDO 3.5 release and its PostgreSQL provider to see if using that provider resolves your issues. However, that would mean you would need to move to the version of MG that is compatible with FDO 3.5.
> Greg
> -----Original Message-----
> From: fdo-users-bounces at lists.osgeo.org [mailto:fdo-users-bounces at lists.osgeo.org] On Behalf Of Heddo Klandermans
> Sent: Friday, November 19, 2010 3:49 AM
> To: fdo-users at lists.osgeo.org
> Subject: [fdo-users] Resource ID does not refer to a valid feature source
> Hi,
> Using MapGuide Studio 2010 I can make a succesful  connection to my
> database by FDO PostGIS connection (PostGreSQL 8.4 + PostGIS 3.4). Also
> (geometric) tables can be read to create layers.
> After performing some changes in the database table structure the Data
> connection was still ok, but MG had problems in getting table-data for
> the layers. I fixed this by a Vacuum Analyse on the database and finally
> a reindex. This worked well and solved the problems.
> After another change in my databse now data connection is still ok, but
> when trying to create a layer i get the message:
> "Invalid Stream Header Exception" followed by "Resource ID does not
> refer to a valid feature source".
> Any attempt to create a new folder and/or data connection in MG using
> FDOPostGIS connecting to that specific database gives the same problem:
> data connection is succesful, when creating a layer it displays these
> messages. Connecting to other databses does not give any problem.
> I think this problem is caused by mismatch between Library settings and
> Database. Did anyone experience similar problems and if so what can be
> done to it?
> Thx,

ir. H.D. (Heddo) Klandermans
Senior Consultant

Hawar Information Technology bv
De Wymerts 7, 8701 WT Bolsward, NL
Postbus 42, 8700 AA Bolsward, NL
Tel.: (+31)-(0)515-570 333
E-mail: h.klandermans at HawarIT.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/fdo-users/attachments/20101123/1170eb04/attachment.html

More information about the fdo-users mailing list