[fdo-users] Problem with FDO King Oracle Provider - unable to load library

Jan Małysiak j.malysiak at hotmail.com
Thu Aug 18 18:09:31 EDT 2011

Hi all,

I am not able to connect to Oracle database using King Oracle Provider. 
I'm trying to establish the connection in MapGuide Maestro, but I 
receive a long message of an error, where I think the most important 
part is "CLNT_8_UNABLE_TO_LOAD_LIBRARY". The same appears in the error 
log, and the same in mapagent when I try to get capabilities for King 
Oracle Provider.
I've already found several descriptions of similar problems posted by 
other users, but unfortunately none of them solved my problem. I have 
added the provider entry in providers.xml file, downloaded Oracle 
Instant Client, added its path to LD_LIBRARY_PATH, checked dependencies 
for libKingOracleProvider.so, copied required Oracle libraries to 
FDO/lib directory, now when I run ldd command for the 
libKingOracleProvider.so it says that all required libraries are found, 
nevertheless the error establishing new connection still occurs.

I use:

MapGuide Open Source 2.1.0
FDO 3.4.0
MapGuide Maestro 2.1.4
Ubuntu 10.10
Oracle Instant Client

I'm not sure of the version of King Oracle Provider as I downloaded it 
in an archive together with other FDO providers.

I would be very thankful for any help.

Best regards,
Jan Małysiak

More information about the fdo-users mailing list