[fdo-users] OGR Oracle connection problem

Jan Małysiak j.malysiak at hotmail.com
Mon Aug 22 08:23:45 EDT 2011


I would like to connect MapGuide OpenSource to Oracle Spatial database, I
use Ubuntu and I've already learned that KingOracle Provider does not work
on Linux, so now I attempt to make a connection using OSGeo FDO Provider for
OGR. When I test connection in MapGuide Maestro I get "The remote server
returned an error: (559) MgFdoException.: An exception occurred in FDO
component.". For more details, I looked at error log and that's what I read:

<2011-08-22T14:08:14>     -1388410000    MapGuide Maestro v2.1.4.5245    Administrator
 Error: An exception occurred in FDO component.
        Connect failed:
  - MgFeatureServiceHandler.ProcessOperation() line 83 file
  - MgOpTestFeatureSourceConnection.Execute() line 100 file
  - MgFdoConnectionManager.Open() line 893 file FdoConnectionManager.cpp

I've searched a lot for similar problems, but I couldn't find any working
solution. I've tried multiple various configurations of connection
parameters, I've tried also adding Oracle client path to LD_LIBRARY_PATH,
but still all my attempts were unsuccessful.

I use:
MapGuide Open Source 2.1.0
FDO 3.4.0
MapGuide Maestro 2.1.4
Ubuntu 10.10
Oracle Instant Client

Thank you for any help.

Best regards,
Jan Małysiak
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/fdo-users/attachments/20110822/466e920a/attachment.html

More information about the fdo-users mailing list