[fdo-users] Trying to debug issues in FDO's SQL Server Spatial provider

Sören Kuklau S.Kuklau at trenz.ag
Wed May 25 05:04:45 EDT 2011


first of all, I'm unsure if -users or -internals is the appropriate mailing list; I'd be willing to try and make changes to the codebase if it helps fix the issues.

a customer is experiencing various issues with the MS SQL Server Spatial provider in AutoCAD Map 3D 2012 (FDO 3.6). _I cannot reproduce these issues in Map 3D 2010 (FDO 3.4)_, so I'm assuming that they are caused by changes on AutoCAD's or FDO's end:

1) I can no longer add views as layers if one of their columns contains an umlaut (e.g. "Grundstück").
2) AutoCAD now throws a "Item dbo.<name of a function> is already in this named collection." warning. Apparently, this occurs if the same function is used by multiple views.

Those two can be easily worked around, but if I have a chance to fix them, I wouldn't mind. :) However, then there's this one:

3) If checking in to a table with an INSTEAD OF INSERT trigger, AutoCAD either shows an "invalid cursor state" message (this appears related to this post: http://osgeo-org.1803224.n2.nabble.com/autocad-2011-commit-changes-problem-td6180452.html), or, in most cases, crashes with a "FATAL ERROR: Unhandled Access Violation Reading 0x0000 Exception at <ever-changing memory address>" message. My guess is that this is caused by r4552 (http://trac.osgeo.org/fdo/ticket/507).

I've managed to set up a build environment both for the /branches/3.6 supplied with AutoCAD Map 3D 2012 as well as with /trunk (from Subversion). Thus far, I've been unsuccessful getting those custom builds to run in AutoCAD: if I install _all_ DLLs generated by build_thirdparty and build (fdo, sqlspatial), the Data Connect panel is entirely empty with a "failed to load" message; if I merely add all SqlSpatial-related DLLs to the provider.xml or replace the existing one with my custom build (I've also tried using a sub-directory), it fails to load those. Which files in particular can I replace to reproduce this? Is doing a debug build with .pdb files and then loading the acminidump.dmp into VS 2010 at all feasible?

In addition, I've tried running FDO Toolbox, which uses FDO 3.6 as well, but oddly does not exhibit the third problem.

Thanks in advance for any pointers,
Sören Kuklau

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/fdo-users/attachments/20110525/5fe3ceba/attachment.html

More information about the fdo-users mailing list