Hi Orest,<br><br>Thanks very much, appreciate your help. I&#39;ll use one of the later versions.<br><br>Regards,<br>Snehal<br><br><div class="gmail_quote">On Wed, May 9, 2012 at 8:54 AM, Orest Halustchak <span dir="ltr">&lt;<a href="mailto:orest.halustchak@autodesk.com" target="_blank">orest.halustchak@autodesk.com</a>&gt;</span> wrote:<br>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">





<div link="blue" vlink="purple" lang="EN-US">
<div>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d">That looks like an old note. You should use 10.0 or 9.3.1.<u></u><u></u></span></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d"><u></u>†<u></u></span></p>
<p class="MsoNormal"><b><span style="font-size:10.0pt;font-family:&quot;Tahoma&quot;,&quot;sans-serif&quot;">From:</span></b><span style="font-size:10.0pt;font-family:&quot;Tahoma&quot;,&quot;sans-serif&quot;"> <a href="mailto:fdo-users-bounces@lists.osgeo.org" target="_blank">fdo-users-bounces@lists.osgeo.org</a> [mailto:<a href="mailto:fdo-users-bounces@lists.osgeo.org" target="_blank">fdo-users-bounces@lists.osgeo.org</a>]
<b>On Behalf Of </b>Snehal Joshi<br>
<b>Sent:</b> Wednesday, May 09, 2012 9:50 AM</span></p><div><div class="h5"><br>
<b>To:</b> FDO Users Mail List<br>
<b>Subject:</b> Re: [fdo-users] building FDO source code on Windows<u></u><u></u></div></div><p></p><div><div class="h5">
<p class="MsoNormal"><u></u>†<u></u></p>
<p class="MsoNormal" style="margin-bottom:12.0pt">Hi Orest,<br>
<br>
Thanks again for the helpful information. I&#39;ve one last question that has been bothering me -<br>
<br>
&gt;From <a href="http://fdo.osgeo.org/files/fdo/docs/OpenSourceBuild__README.html" target="_blank">http://fdo.osgeo.org/files/fdo/docs/OpenSourceBuild__README.html</a>, in Build Notes section, it says that in order to build the ArcSDE provider, you&#39;ll need to have the ArcSDE
 9.1 client SDK installed. How strict is the version dependency? I see there is major release of ArcGIS software after 9.1.<br>
<br>
Regards,<br>
Snehal<br>
<br>
<u></u><u></u></p>
<div>
<p class="MsoNormal">On Wed, May 9, 2012 at 7:19 AM, Orest Halustchak &lt;<a href="mailto:orest.halustchak@autodesk.com" target="_blank">orest.halustchak@autodesk.com</a>&gt; wrote:<u></u><u></u></p>
<div>
<div>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d">Hi Snehal,</span><u></u><u></u></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d">†</span><u></u><u></u></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d">I believe thatís correct, that the sdk provides the necessary libraries. Make sure that you get the
 correct version of the sdk for 32 or 64 bit. I donít know if there is one sdk for both platforms or if there are separate sdkís.</span><u></u><u></u></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d">†</span><u></u><u></u></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d">Orest.</span><u></u><u></u></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d">†</span><u></u><u></u></p>
<p class="MsoNormal"><b><span style="font-size:10.0pt;font-family:&quot;Tahoma&quot;,&quot;sans-serif&quot;">From:</span></b><span style="font-size:10.0pt;font-family:&quot;Tahoma&quot;,&quot;sans-serif&quot;">
<a href="mailto:fdo-users-bounces@lists.osgeo.org" target="_blank">fdo-users-bounces@lists.osgeo.org</a> [mailto:<a href="mailto:fdo-users-bounces@lists.osgeo.org" target="_blank">fdo-users-bounces@lists.osgeo.org</a>]
<b>On Behalf Of </b>Snehal Joshi<br>
<b>Sent:</b> Tuesday, May 08, 2012 11:00 PM<br>
<b>To:</b> FDO Users Mail List<br>
<b>Subject:</b> Re: [fdo-users] building FDO source code on Windows</span><u></u><u></u></p>
<div>
<div>
<p class="MsoNormal">†<u></u><u></u></p>
<p class="MsoNormal">Hi Orest,<u></u><u></u></p>
<div>
<p class="MsoNormal">†<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">Many thanks for your help. I&#39;ve one more follow-up question -†<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">†<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">Would the ArcSDE SDK installer †also provide the SDE client libraries needed at run-time? (I&#39;m assuming these are sg.dll, sde.dll, and pe.dll).†<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal">†<u></u><u></u></p>
</div>
<div>
<p class="MsoNormal" style="margin-bottom:12.0pt">Snehal<u></u><u></u></p>
<div>
<p class="MsoNormal">On Tue, May 8, 2012 at 7:17 PM, Orest Halustchak &lt;<a href="mailto:orest.halustchak@autodesk.com" target="_blank">orest.halustchak@autodesk.com</a>&gt; wrote:<u></u><u></u></p>
<div>
<div>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d">Hi,</span><u></u><u></u></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d">†</span><u></u><u></u></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d">It uses the C API, which you can get from the ArcSDE SDK. You donít need the ArcSDE server just to
 build the provider, but you will need the SDE client libraries to run the provider.</span><u></u><u></u></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d">†</span><u></u><u></u></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d">Orest.</span><u></u><u></u></p>
<p class="MsoNormal"><span style="font-size:11.0pt;font-family:&quot;Calibri&quot;,&quot;sans-serif&quot;;color:#1f497d">†</span><u></u><u></u></p>
<p class="MsoNormal"><b><span style="font-size:10.0pt;font-family:&quot;Tahoma&quot;,&quot;sans-serif&quot;">From:</span></b><span style="font-size:10.0pt;font-family:&quot;Tahoma&quot;,&quot;sans-serif&quot;">
<a href="mailto:fdo-users-bounces@lists.osgeo.org" target="_blank">fdo-users-bounces@lists.osgeo.org</a> [mailto:<a href="mailto:fdo-users-bounces@lists.osgeo.org" target="_blank">fdo-users-bounces@lists.osgeo.org</a>]
<b>On Behalf Of </b>Snehal Joshi<br>
<b>Sent:</b> Tuesday, May 08, 2012 1:51 PM<br>
<b>To:</b> <a href="mailto:fdo-users@lists.osgeo.org" target="_blank">fdo-users@lists.osgeo.org</a><br>
<b>Subject:</b> [fdo-users] building FDO source code on Windows</span><u></u><u></u></p>
<div>
<p class="MsoNormal">†<u></u><u></u></p>
<p class="MsoNormal" style="margin-bottom:12.0pt">Hi All,<br>
<br>
I am trying to compile FDO source code on Windows. From the build instructions, I figured I&#39;d need to get ArcSDE SDK. I see there are two choices for this - the C-API or the Java SDK. I plan to build the FDO binaries to be used in C++ application. So, I&#39;m assuming
 I could use the C-API. Is that a valid assumption. Also, do I need to have any additional ArcGIS/ArcSDE components installed the machine I use to build FDO code. I don&#39;t have ArcGIS/ArcSDE Server or Oracle on it currently. I have been struggling to get more
 information on this, and will greatly appreciate any pointers. <br>
<br>
Many thanks!<u></u><u></u></p>
</div>
</div>
</div>
<p class="MsoNormal" style="margin-bottom:12.0pt"><br>
_______________________________________________<br>
fdo-users mailing list<br>
<a href="mailto:fdo-users@lists.osgeo.org" target="_blank">fdo-users@lists.osgeo.org</a><br>
<a href="http://lists.osgeo.org/mailman/listinfo/fdo-users" target="_blank">http://lists.osgeo.org/mailman/listinfo/fdo-users</a><u></u><u></u></p>
</div>
<p class="MsoNormal">†<u></u><u></u></p>
</div>
</div>
</div>
</div>
</div>
<p class="MsoNormal" style="margin-bottom:12.0pt"><br>
_______________________________________________<br>
fdo-users mailing list<br>
<a href="mailto:fdo-users@lists.osgeo.org" target="_blank">fdo-users@lists.osgeo.org</a><br>
<a href="http://lists.osgeo.org/mailman/listinfo/fdo-users" target="_blank">http://lists.osgeo.org/mailman/listinfo/fdo-users</a><u></u><u></u></p>
</div>
<p class="MsoNormal"><u></u>†<u></u></p>
</div></div></div>
</div>

<br>_______________________________________________<br>
fdo-users mailing list<br>
<a href="mailto:fdo-users@lists.osgeo.org">fdo-users@lists.osgeo.org</a><br>
<a href="http://lists.osgeo.org/mailman/listinfo/fdo-users" target="_blank">http://lists.osgeo.org/mailman/listinfo/fdo-users</a><br>
<br></blockquote></div><br>