[FOSS-GPS] FoxtrotGPS, terminology: "routes" and "waypoints" vs. "routepoints"?

Joshua Judson Rosen rozzin at geekspace.com
Sun Sep 9 20:24:10 PDT 2012

FoxtrotGPS recently got a lovely patch to add route-planning
functionality <https://bugs.launchpad.net/foxtrotgps/+bug/1035343>,
and now there seems to be a conflict of terminology: between
the `routes' manipulated by operations in the new *route-planning*
functionality vs. the `routes' drawn by the pre-existing
*route-finding* functionality; and between the pre-existing
`waypoint' functionality vs. the `waypoints' used to plan routes.

I'm not sure what the right way to handle this is, and I'd love
some advice. Here's a copy of the thoughts that have been posted
to the bug-tracker <https://bugs.launchpad.net/foxtrotgps/+bug/1035343>
so far:

"Dr. Tilmann Bubeck" <t.bubeck at reinform.de> writes:
> * waypoints/trackpoints/routepoints? Well, I think we are planing a
>   route consisting of routepoints (rtept). However, some web pages speak
>   of routes consisting of waypoints, so I think this is not very clear
>   by definition. Regardless of what we write into our generated GPX
>   files we are able to read "rtept" and also "waypt", but not "trackpt"
>   which is for tracking a route which you already travelled. So I did
>   not change anything, because I do think that it is consistent.


> In addition I reordered the entries of the "route & wp" menu. I moved
> all entries dealing with single points at the top of the menu and all
> entries dealing with all waypoints (=routes) to the end.

Regardless of the ordering of the menu-items, I think it ends up being
confusing because each of "route" and "WP" both now mean multiple,
different things:

    * The pre-existing "get route" just draws a non-editable route
      (like you'd get when loading a *track* from a GPX file).
    * Your new "load route from GPX" loads a series of editable
      routepoints, and has nothing to do with "get route"
      (likewise "save route as GPX" has nothing to do with the `route'
       generated by "get route"; and "clear route" clears only
       your `route of waypoints', not routes from "get route").

    * The pre-existing "set WP" and "unset WP" do something
      orthogonal to your "add WP", "delete WP", and "insert WP before"

One thought I had on this was we could try to disambiguate the different
features by moving them to different menus (e.g.: "route planning"
vs. "route finding").... But, based upon your explanation above,
I wonder if the best option is actually just to label your new operations
as being `routepoint' operations rather than `route' or `waypoint'
operations. Something like:

    * add routepoint
    * insert routepoint before this
    * delete routepoint
    * clear routepoints
    * save routepoints to GPX route
    * save routepoints to TomTom ITN

Or is that also confusing? Would it be better to do something like:

    * clear planned route
    * save planned route to GPX
    * save planned route to TomTom ITN

We could also resolve the "WP" conflict by renaming the historic WP
menu-items, e.g.:

    * set target
    * unset target


"Don't be afraid to ask (λf.((λx.xx) (λr.f(rr))))."

More information about the FOSS-GPS mailing list