[gdal-dev] Undefined symbol in _gdalmodule.so: OSRSetStatePlane

Frank Warmerdam warmerda at h...
Mon Oct 23 10:00:04 EDT 2000

Aleksey Naumov wrote:
> Hi all,
> Just downloaded the latest from CVS and compiled, then tried to
> test GDAL from Python (I am using 2.0). I got an "undefined symbol"
> problem:
> Python 2.0 (#1, Oct 19 2000, 00:29:59)
> [GCC 2.95.2 19991024 (release)] on linux2
> Type "copyright", "credits" or "license" for more information.
> >>> import gdal
> Traceback (most recent call last):
> File "<stdin>", line 1, in ?
> File "/usr/local/lib/python2.0/site-packages/gdal.py", line 75, in ?
> import _gdal
> ImportError: /usr/local/lib/python2.0/site-packages/_gdalmodule.so:
> undefined symbol: OSRSetStatePlane
> This symbol is also not in libgdal.1.1.so, and that's the only
> GDAL-specific library
> _gdalmodule.so depends on.
> Am I missing something?


Sorry about that. I neglected to commit gdal/ogr/ogr_fromepsg.cpp changes.
Please do a cvs update and make again. You shouldn't need to do a clean build
or anything like that. 

Note that I have never tried the GDAL python bindings with Python 2.0. I 
would appreciate hearing if it works or not. 

Best regards,

I set the clouds in motion - turn up | Frank Warmerdam, warmerda at h...
light and sound - activate the windows | http://members.home.com/warmerda
and watch the world go round - Rush | Geospatial Programmer for Rent

More information about the Gdal-dev mailing list