[Gdal-dev] gdal_merge.py question

Frank Warmerdam warmerdam at pobox.com
Tue Aug 12 12:42:14 EDT 2003

Stephen H. Savage wrote:

> Greetings,
>    I'm still having difficulties getting gdal_merge to work.  I've installed 
> the latest version of OpenEV.  After installing the OpenEV 1.6 software, the 
> environment variables are set as follows:
> set OPENEV_HOME=C:\PROGRA~1\Atlantis\OPENEV~1.60
> set path=%OPENEV_HOME%\bin;%OPENEV_HOME%\python\Lib;%PATH%
> I tried to run this command from a DOS prompt
> c:\Program Files\Atlantis\OpenEV 1.60pymod\gdal_merge.py -n 0 -o testout.tif 
> c:\ImageFix\34e29n_36.tif c:\ImageFix\34e30n_36.tifpymod\gdal_merge.py -n 0 -o 
> testout.tif c:\ImageFix\34e29n_36.tif c:\ImageFix\34e30n_36.tif
> It reports this in the DOS window:
> Traceback (most recent call last):
>    File "C:Program Files\Atlantis\OpenEV 1.60\pymod\gdal_merge.py", line 55, 
> in ?
> 	import gdal
>    File "C:Program Files\Atlantis\OpenEV 1.60\pymod\gdal_merge.py", line 156, 
> in ?
> 	import _gdal
> ImportError: Module use of pyton21.dll conflicts with this version of Python.
> I tried to register gdal11.dll by hand with RegSrvr.exe, but it couldn't do it.
> Any suggestions?


I have kind of lost the thread of this issue.  I would note that 1.60 is
not the most recent release of OpenEV, the OpenEV_FW 1.6.2 is though 1.60
is the most recent formal Atlantis release.   Are you using a GDAL you
built with the 1.6.0 OpenEV distribution?  It would appear that GDAL's
python bindings are compiled with a different version of python than the
one distributed with OpenEV.

Best regards,

I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | Geospatial Programmer for Rent

More information about the Gdal-dev mailing list