[Gdal-dev] Problem Unable to load PROJ.4

roni zanolli rzanolli at hotmail.com
Tue Feb 18 10:18:00 EST 2003

Hi All,

I installed gdal-1.1.8 and I'm using it with Virtual Terrain Project. My O.S 
is linux suse 8.1 and when I tried to convert a projection coordinate from 
nad27 to nad83 I get a error message

ERROR 6: Unable to load PROJ.4 library (libproj.so), creation of
OGRCoordinateTransformation failed.

I installed proj-4.4.5 and the libproj.so is locate in /usr/local/lib and my 
ldconfig is set up to look to this path.

Debugging the code I found that the file cplgetsymbol.cpp is using Dummy 
implementation instead of Unix Implemnetation because HAVE_DLFCN_H was not 
define when running configure prior to the instalation.

So I run configure again and figure out that it is not findind most of my 
header files like
dlfcn.h, unistd.h, fcntl.h.

Can somebody help me with this problem?

Thank you,


MSN 8 with e-mail virus protection service: 2 months FREE*  

More information about the Gdal-dev mailing list