[Gdal-dev] Problem getting ECW SDK 3.1 working with gdal

Brent Fraser bfraser at geoanalytic.com
Wed Apr 6 17:49:09 EDT 2005


  I'm successfully using:

    GDAL 1.2.6
    VS .Net 2003
    MicroSoft Platform SDK

Download the Core portion of the MicroSoft Platform SDK:


Edit GDAL's nmake.opt to include the path to the Microsoft SDK:

INC = -I$(GDAL_ROOT)\port -I$(GDAL_ROOT)\ogr -I$(GDAL_ROOT)\gcore \
  -I$(GDAL_ROOT)\alg -IC:\PROGRA~1\MIFD68~1\include

I think that's it...

Brent Fraser

----- Original Message ----- 
From: "Thom DeCarlo" <t.r.decarlo at larc.nasa.gov>
To: "'gdal-dev'" <gdal-dev at remotesensing.org>
Sent: Wednesday, April 06, 2005 3:09 PM
Subject: [Gdal-dev] Problem getting ECW SDK 3.1 working with gdal

> I've just downloaded the latest ECW J2000 SDK from the ermapper site. I've
> also updated to the latest gdal tarball. I'm using WinXP SP1 and
> First I tried to use the ECW SDK binaries. When the build got to the ecw
> directory I got an error saying there was a missing file:
> C:\Svs_dev_C\gdal-cvs-20050405\frmts>cd ecw   && nmake /NOLOGO /f
> makefile.vc   && cd ..
>         cl /nologo /MD /GX /Zi /Fd..\..\gdal.pdb -I..\..\port
> -I..\..\ogr -I..\..\gcore  -I..\..\alg
> -I"C:\Program Files\Earth Resource Mapping\ECW SDK"\include
> /DWIN32 -DFRMT_ecw -DNO_X86_MMI /c ecwdataset.cpp
> ecwdataset.cpp
> c:\Svs_dev_C\gdal-cvs-20050405\frmts\ecw\vsiiostream.h(74) : fatal error
> C1083: Cannot open include file: 'NCSJP2File.h': No such file or directory
> NMAKE : fatal error U1077: 'cl' : return code '0x2'
> Stop.
> NMAKE : fatal error U1077: 'for' : return code '0x2'
> Stop.
> NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio .NET
> 2003\VC7\BIN\nmake.exe"' : return code '0x2'
> Stop.
> And, sure enough, there is no file called NCSJP2File.h in the ECW include
> directory.
> I then downloaded the ECW SDK source code and tried to compile it. First,
> the IDE complained that new projects had been added to the solution and it
> couldn't connect to the SourceSafe server. Once I got past that and got
> include paths lined up I attempted to follow the instructions in the
> build.txt file. Now it is complaining that it cannot find the file
> "winhttp.h". A search of the computer proved that, indeed, that file is
> nowhere to be found.
> What did you folks do to get this stuff to compile?
> TIA,
> Thom
> --
> Thom DeCarlo
> --------------------------------------------------
>      Do Not Meddle in the Affairs of Dragons
>  For You are Crunchy and Taste Good with Ketchup
> _______________________________________________
> Gdal-dev mailing list
> Gdal-dev at xserve.flids.com
> http://xserve.flids.com/mailman/listinfo/gdal-dev

More information about the Gdal-dev mailing list