[Gdal-dev] GDAL building for Windows CE

Mateusz Loskot mateusz at loskot.net
Tue Nov 7 07:45:22 EST 2006

kiruba nantham wrote:
> Yes first i was trying to build gdal-1.3.2. but now i tried with
> GDAL from CVS too, still i am getting same error (fatal error 
> c1083:cannot open include file stdio.h:nosuch file or directory).

First, the stdio.h file comes from Windows CE/Mobile SDK,
so check if you have SDK installed and if INCLUDE and LIB paths are
configured and accessible from command line.
On my box, I have Visual C++ 2005 with Windows Mobile 5.0 SDK and this
file is here:

"C:\Program Files\Windows CE Tools\wce500\Windows Mobile 5.0 Pocket PC

I have not instaled eVC++ 4.0 so I can't check it at the moment.
I'll try to install this compiler during the weekend and see what happen.

Second, I don't know where stdio.h file can not be included, in what
file, because I couldn't open the build log you attached.
Please, next time use portable format like plain TXT or HTML,
so it's easier to open it with text editor but not with Microsoft
Office. Thanks!

> I am following exactly same as you said to build the GDAL for Windows
> CE at wince.html ("Building GDAL port using eVC++ and makefiles") but
> still i am getting this error.

> Workspace of  GDAL from
> CVS(evc4_gdalce_dll.vcw)  is not opening in *Embedded c++ 4.0 *at
> all.

Hmm, that's strange.
What errors you get?
I suppose there may be a problem with end-of-line characters, LF instead
of CRLF.
Try to convert EOL in all .vcp and .vcw files and see if it works.

As I said, I am not able to check it with eVC++ 4.0 now.
I'll do it in the weekend.

Mateusz Loskot

More information about the Gdal-dev mailing list