[Gdal-dev] gdal install errors

Martin Wegmann wegmann at biozentrum.uni-wuerzburg.de
Thu Nov 9 11:32:59 EST 2006


On Thursday 09 November 2006 16:27, you wrote:
> Martin Wegmann wrote:
> > Hello,
> >
> > I tried on a fresh debian testing system to install the official gdal
> > 1.3.2 source code and the cvs code (today), both resulted in the error
> > messages below when executing make.
> >
> > Any hint, how to fix it is appreciated.
> >
> > regards, Martin
> Martin,
> Could you try this with a CVS snapshot to verify this isn't already fixed
> since spring?  
I tried it with this cvs snapshot:
% export CVSROOT=:pserver:cvsanon at cvs.maptools.org:/cvs/maptools/cvsroot
% cvs login
Password: *enter*
% cvs checkout gdal

> You might also try installing GDAL without GRASS support, 
> and then building and installing the grass driver as a plugin.  This can
> be done using:

without grass support

It works so far:
gdal_rasterize.o -o .libs/gdal_rasterize  /home/baliola/software/gdal_cvs/gdal/.libs/libgdal.so -lpthread -lmfhdf -ldf -lgif -lpng -lnetcdf -lcfitsio -L/usr/lib -lpq -lz -lrt -ldl -Wl,--rpath -Wl,/usr/local/lib
creating gdal_rasterize
make[1]: Leaving directory `/home/baliola/software/gdal_cvs/gdal/apps'

but when I install gdal-grass:
./configure --with-gdal=/usr/local/bin/gdal-config --with-grass=/usr/local/grass-6.3.cvs/                 

grass57dataset.cpp: In static member function ‘static GDALDataset* 
grass57dataset.cpp:948: error: ‘GPJ_grass_to_wkt’ was not declared in this 
make: *** [grass57dataset.o] Error 1

it's the same error message like with grass-support, isn't it?

thanks for your help, regards, Martin

>    http://www.gdal.org/dl/gdal-grass-1.3.2.tar.gz
> The plugin is more used, and better tested these days.
> Best regards,

More information about the Gdal-dev mailing list