[Gdal-dev] Error making GDAL CVS daily "snapshot"

Bill Thoen bthoen at gisnet.com
Thu Nov 30 11:23:24 EST 2006

I just tried to build the latest version of GDAL from the CVS daily
snapshot and got this error:

[stuff clipped]...
g++: /usr/lib/libidn.so: No such file or directory
make[1]: *** [libgdal.la] Error 1
make[1]: Leaving directory `/home/bthoen/gdal-cvs-2006.11.30'
make: *** [check-lib] Error 2

Sure enough, when I look in /usr/local/lib, libidn.so is not there. but the
gdal libraries from when I last built the official 1.10.0 release are

$ ls -al /usr/local/lib | grep gdal
-rw-r--r--  1 root root  7629336 Sep 11 13:09 libgdal.a
-rwxr-xr-x  1 root root      912 Sep 11 13:09 libgdal.la
lrwxrwxrwx  1 root root       17 Sep 11 13:09 libgdal.so -> libgdal.so.1.10.0
lrwxrwxrwx  1 root root       17 Sep 11 13:09 libgdal.so.1 -> libgdal.so.1.10.0
-rwxr-xr-x  1 root root  4355642 Sep 11 13:09 libgdal.so.1.10.0

I've also set LD_LIBRARY_PATH to /usr/local/lib and run ldconfig (just
wildly stabbing at anything that looks good) and tried 'make install'
again. No luck. 

Does anyone know how I can fix this?

- Bill Thoen

More information about the Gdal-dev mailing list