[Gdal-dev] gdalwarp error 33

Frank Warmerdam warmerdam at pobox.com
Tue Oct 24 14:59:32 EDT 2006

Naiara Pinto wrote:
> Hi all,
> I have the most recent version of FWTools and I am having trouble
> using Gdalwarp in one of my layers. Here is what I did:
> gdalwarp -s_srs '+proj=longlat +ellps=WGS84 +datum=WGS84 +no_defs'
> -t_srs '+proj=aea +lat_1=29.5 +lat_2=45.5 +lat_0=23 +lon_0=-96 +x_0=0
> +y_0=0 +ellps=GRS80 +datum=NAD83 +units=m +no_defs' -tr 500 500 -rb
> -srcnodata 251 -dstnodata -9999 LatLon.NA.2001.Tree.tif ptree.tif
> I am getting the following error:
> Creating output file that is 36225P x 17963L.
> ERROR 1: no system list, errno: 33
> ERROR 1: GDALWarperOperation::ComputeSourceWindow() failed because
> the pfnTransformer failed.
> *** glibc detected *** corrupted double-linked list: 0x08078570 ***
> Aborted
> I have used this dataset before and it worked ok when I tried to
> project it to Lambert Azimuthal Equal Area. But now that I am trying
> to project it to Albers Equal Area, I am getting the error above.
> Does anyone have any ideas why this happens?


The failure to reproject can be for a number of reasons, including that
the location is invalid for the projection specified.  Many projections
don't support "over the horizon" locations for instance.

If you would like me to reproduce the problem, I would need a gdalinfo
report for the source file.

Best regards,
I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | President OSGeo, http://osgeo.org

More information about the Gdal-dev mailing list