[Gdal-dev] Converting to GMT

Frank Warmerdam warmerdam at pobox.com
Tue Feb 13 10:13:27 EST 2007

Jose Luis Gomez Dans wrote:
> Joaquim,
>>> I get the following error:
>>> gdal_translate -of GMT test.tif testOut.grd
>>> Input file size is 1347, 1032
>>> netcdf: 3 is not a valid cdfid
>> I just tried that transformation and it worked ok (1.4.0 on Win XP)
>> It only failed to convert the
>> NoData Value=-99999
>> to NaN as is expected for the default value on GMT grids
> Hmmm, it also works fine on Win2k (GDAL, FWTools 1.0.0a6, released 2005/11/03), but fails on my Linux box, and with the latest GDAL installed. i wonder why?


I'm not sure, but I reproduced the same error message about "cdfid".  I
don't think I'll have time to build the netcdf libraries in debug and
track through to see what is happening today, so I'd appreciate it if you
could file a bug in the GDAL bugzilla about the issue.  You might note
in the bug that is also occurs "on Frank's Ubuntu system using the packaged
libnetcdf" as a reminder to me, or Mateusz.

I vaguely suspect some sort of hdf4/netcdf problems but I'm not sure.

In the meantime, it appears that the FWTools for linux build for netcdf
is working for me.

Best regards,
I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | President OSGeo, http://osgeo.org

More information about the Gdal-dev mailing list