[Gdal-dev] Personal Geodatabase - Unknown Geometry

Stuart Eve stuarteve at lparchaeology.com
Sat Feb 17 08:15:12 EST 2007

Dear all

I have been attempting to get the PGeo driver up and running on a
Suse10.1 box using gdal-1.4.0, mdbtools-6pre1 and unixODBC 2.2.12.

After some helpful conversations with Mateusz I managed to get the
odbc.ini set up right etc. However, now when I run an ogrinfo on the
geodatabase it never seems to find the geometry type - and therefore
when I try to show the features using mapserver all I get is an empty
map. I have tried it on 3 different geodatabases (8.2 and 9.x) with the
same result.

Has anyone got any ideas?



my ogrinfo output from (ogrinfo pgeo:DNSNAME Objects) is below:

Layer name: Objects
Geometry: Unknown (any)
Error at Line : syntax error near (
ERROR 1: GetFeatureCount() failed on query SELECT COUNT(*) FROM Objects.

Feature Count: -1
Extent: (500680.200000, 99106.570000) - (500684.500000, 99135.000000)
Layer SRS WKT:
OBJECTID: Integer (0.0)
FeatureNum: Integer (0.0)
LocalArea: String (0.0)
Drawing: String (0.0)
ObjFieldID: String (0.0)
ObjectType: String (0.0)
Elevation: Real (0.0)
Notes: String (0.0)
EntryPerson: String (0.0)
ObjSuffix: Integer (0.0)
ObjNumber: Integer (0.0)
  OBJECTID (Integer) = 1
  FeatureNum (Integer) = 1718
  LocalArea (String) = GIII.4
  Drawing (String) = 1999-6
  ObjFieldID (String) = 2
  ObjectType (String) = Alabaster tool
  Elevation (Real) = 15.97
  Notes (String) = (null)
  EntryPerson (String) = RLM
  ObjSuffix (Integer) = (null)
  ObjNumber (Integer) = (null)

... carries on listing the feature attributes.

More information about the Gdal-dev mailing list