[Gdal-dev] problem compiling 1.4.0 on mac os x 10.4

John Cartwright John.C.Cartwright at noaa.gov
Wed Mar 14 12:04:23 EDT 2007

Hi Eric,

The "--with-libz=external" option worked perfectly.  Thanks for your help!

-- john

Eric Dönges wrote:
> Am 05.03.2007 um 23:43 schrieb John Cartwright:
>> Hello All,
>> I'm having a little trouble compiling 1.4.0 on my mac.  The 1.3.x 
>> series compiled just fine on the same machine.  Lots of messages like:
>> /usr/bin/ld: warning multiple definitions of symbol _get_crc_table
>> /usr/local/src/gdal-1.4.0/.libs/libgdal.dylib(single module) 
>> definition of _get_crc_table
>> /usr/lib/libz.dylib(crc32.o) definition of _get_crc_table
>> Any ideas?
> You are having a linker conflict between the libz internal to GDAL and 
> the system's
> libz. To resolve this, you need to either not link against the 
> system's libz in any
> files linking against libgdal, or configure gdal to not use the 
> internal libz
> (try configuring with --without-libz or --with-libz=external - I 
> haven't tried this
> myself, but one of the above should work). Since doing the former 
> might be rather
> difficult in practice, and MacOS includes libz by default anyway, I 
> would recommend
> trying the later.
> With kind regards,
> Eric

More information about the Gdal-dev mailing list