[gdal-dev] gdalwarp cutting off projected image

Frank Warmerdam warmerdam at pobox.com
Tue Dec 9 14:08:15 EST 2008

Scott Lewis wrote:
> Frank,
> Thanks for the help.  I tried doing this, and ended up with the same 
> image (even diff found them to be the same).  Here are the various 
> commands I tried.  Maybe I'm just using the -wo option wrong.
> gdalwarp -t_srs EPSG:4326 -wo SOURCE_EXTRA=1000 input.gtiff.tif 
> output1.gtiff.tif
> gdalwarp -t_srs EPSG:4326 -wo "SOURCE_EXTRA=1000" input.gtiff.tif 
> output2.gtiff.tif
> gdalwarp -t_srs EPSG:4326 -wo "SOURCE_EXTRA=1000 SAMPLE_GRID=YES 
> SAMPLE_STEP=100" input.gtiff.tif output3.gtiff.tif
> I'll continue to play with those options, though.  gdalwarp seems to not 
> act any different (IE, it takes the same amount of time to process) with 
> or without the -wo option, so I'm thinking I'm just not using the option 
> correctly somehow.
> Again, I appreciate your help!


I suspect I've misconstrued what is going wrong.  If you can stage
the input file somewhere, and if it isn't too terribly huge, I would
be interested in trying it myself.  Ideally this could be filed as a
Trac ticket.

Best regards,
I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | Geospatial Programmer for Rent

More information about the gdal-dev mailing list