[gdal-dev] thuban/ gdal : ERROR 4 not recognized format

Didrik Pinte lists at dipole-consulting.com
Wed Jul 8 20:43:00 EDT 2009


I am trying to solve an annoying bug in Thuban. Thuban uses a python
gdalwarp module to reproject raster files.

Since gdal 1.5, everything worked fine. But now the following problem

Loading a new raster in Thuban is done like this :
1. Open the file using gdal.Open() to get some info
2. Open the file using gdal.Open() to get the bbox
3. Reproject and draw the file using a python gdalwarp module [1]
When loading the first raster, the file is displayed correctly but after
that every trial to load another file gives the following error (even
loading the same file that worked at the first use):

ERROR 4: `[...]/current/thuban/Data/iceland/island.tif' not recognised
as a supported file format.

The gdal.Open methods continuously return None. There seem to be some
corruption of the module there but I really do not know how to debug

Do someone know how to debug/solve that ? What could be the cause of
this ?

Thanks in advance for any help.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
Url : http://lists.osgeo.org/pipermail/gdal-dev/attachments/20090709/5c2c9237/attachment.bin

More information about the gdal-dev mailing list