[gdal-dev] Unsupported SRS but available in epsg file

Guillaume Sueur no-reply at neogeo-online.net
Tue Nov 17 04:57:18 EST 2009


Don't want to bother you guys, but I'm running into an unsupported SRS
problem I haven't been able to solve on my own for  the past hours...
I'm running geodjango on a legacy server, which is said to be running
Fedora 9, with standard packages for this distro :
epsg file is located in /usr/share/proj/epsg
I have added to that file the famous 900913 definition, in a proper way,
like I always do :
# Google Spherical Mercator definition
<900913> +proj=merc +a=6378137 +b=6378137 +lat_ts=0.0 +lon_0=0.0
+x_0=0.0 +y_0=0 +k=1.0 +units=m +nadgrids=@null +no_defs <>

When I try to create a SpatialReference with 900913 code, I run into a
SRSException: Unsupported SRS

Same if I run ogr2ogr on a shapefile to project it to Spherical
Mercator :
ogr2ogr -f 'ESRI Shapefile' -t_srs 'EPSG:900913' test.shp
ERROR 6: EPSG PCS/GCS code 900913 not found in EPSG support files.  Is
this a valid
EPSG coordinate system?
Failed to process SRS definition: EPSG:900913

I have browse the disk trying to find another epsg file which could
conflict, without result. 

Any hint would be appreciated ! 

Best regards


More information about the gdal-dev mailing list