[gdal-dev] Is epsg text file read at all when re-projecting with FWTools?

Jukka Rahkonen jukka.rahkonen at mmmtike.fi
Wed Nov 18 09:15:59 EST 2009


With Mapserver I am used to correct projection parameters, if needed, by editing
directly the projection file which is in MS4W package located at
Now I tried to do the same with FWTools 2.4.2.  There is a file with promising
name at \FWTools2.4.2\proj_lib\epsg.  However, I am pretty sure that editing
this file does not change the behaviour of ogr2ogr in any way. Is FWTools taking
the projection definitions from some other place or am I doing something wrong?

What I tried to do was to add +towgs84 parameters. Original line is this 
3067> +proj=utm +zone=35 +ellps=GRS80 +units=m +no_defs  <> 
and I modified it to this:
3067> +proj=utm +zone=35 +ellps=GRS80
+towgs84=0,0,0,0,0,0,0 +units=m +no_defs  <>

FWTools epsg file is having correct parameters for EPSG:2393 projection, but it
seems to me but they are not used either in real use. Only way to get correct
results when reprojecting from epsg:3067 to epsg:2393 is to give both
projections as +proj strings this way

ogr2ogr -f "ESRI Shapefile" output.shp input.shp
-t_srs "+proj=tmerc +lat_0=0 +lon_0=27 +k=1 +x_0=3500000 +y_0=0 
+ellps=intl +towgs84=-96.0617,-82.4278,-121.743,4.80107,0.34543,
-1.37646,1.4964 +units=m"
-s_srs "+proj=utm +zone=35 +ellps=GRS80 
+towgs84=0,0,0,0,0,0,0 +units=m +no_defs"

Giving -t_srs or s_srs as epsg:2393 epsg:3067, respectively, gives a faulty
result which means that +towgs84 parameters are not used at all.

-Jukka Rahkonen-

More information about the gdal-dev mailing list