[gdal-dev] Can't read HDF4 - TRMM

Ivan Lucena ivan.lucena at pmldnet.com
Mon May 24 10:59:13 EDT 2010


I ran gdalinfo on some HDF4 files and no subdataset shows up.

The data is available for download at this website: http://mirador.gsfc.nasa.gov/cgi-bin/mirador/presentNavigation.pl?tree=project&project=TRMM&dataGroup=Gridded&dataset=3B43:%20Monthly%200.25%20x%200.25%20degree%20merged%20TRMM%20and%20other%20sources%20estimates&version=006

I tried reading those some file on:

- Idrisi
- ArcGIS 9.3
- ArcGIS 10 (RC)
- Erdas

They do identify the internal datasets but they cannot identify the reference system and the images they are flipped by 90' clockwise. But that is not due to rotation. I would guess. It is more like a misinterpretation of the dimension parameter, taking rows as columns and columns as rows.  It looks like the documentation for that particular product is missing here: http://mirador.gsfc.nasa.gov/cgi-bin/mirador/servcoll.pl?helpmenuclass=inventory&SearchButton=Search%20GES-DISC

Does anybody has a clue?

BTW. There is a netCDF version of that data that also has some issues.



More information about the gdal-dev mailing list