[gdal-dev] Compile GDAL for x86 on an x64 machine

Joaquim Luis jluis at ualg.pt
Sat Nov 26 19:28:50 EST 2011

On 27-11-2011 00:07, Martin Chapman wrote:
> All,
> I am using a Windows 7 x64 machine with VS 2010 with both x86 and x64 
> compile tools.  When I try to build gdal for x64 using the make file 
> from the Win64 command prompt and WIN64 = YES in the nmake.opt file 
> everything compiles fine.  (using gdal 181 by the way).  If I try to 
> compile it for x86 using the Win86 command prompt and comment out 
> WIN64 in nmake.opt file I always get a linker error where the compiler 
> complains that the target machine doesn't match.  I haven't tried this 
> on my Linux box but now I'm wondering if I am going to have the same 
> issue there as well.
> My question is:  Why can't I compile gdal for x86 on my x64 box?  Am I 
> missing something stupid?  Do you think it's my environment?  Is it 
> supposed to work?  Has anyone else tried to do this?  I think I've 
> done this before with other versions but maybe I am mistaken.

I do build 32 & 64 on my machine that is also Win7 64 and use VC10. You 
probably did the same mistake I often do. Using the VS vcvarsall.bat for 
32 and trying to build the GDAL64 or vice versa.

> On another note.  It would be awesome to have gdal use cmake.  Just a 
> thought.

There are people currently putting that thought to practice.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/gdal-dev/attachments/20111127/cc322f41/attachment-0001.html

More information about the gdal-dev mailing list