[gdal-dev] Installing GDAL with GEOS and Python Bindings on Ubuntu Linux Natty Narwhal 11.04

Duncan Garmonsway nacnudus at gmail.com
Fri Sep 23 22:17:22 EDT 2011


How do you install GDAL with GEOS and the Python Bindings on Ubuntu Linux
Natty Narwhal 11.04?

I've Googled an awful lot and tried heaps of suggestions most of which I'm
afraid I can't remember.  Presumably my system is now in a horrible mess.  I
remember installing umpteen different versions of Python, for example.

Somehow I managed to get enough of GDAL and Python to work to use
gdalbuildvrt and gdal2tiles.py.  But now I want to do something like:

ogr2ogr -s_srs EPSG:2193 -t_srs EPSG:2193 -f "GeoJSON" -clipdst
18785164.071364913 -5009377.0856973119 20037508.342789244 -3757032.814272983
doc-campsites-clipped.json doc-campsites.shp

which responds with hundreds of lines of "ERROR 6: GEOS support not
enabled."  Leaving out "-clip dst", as below, works though.

ogr2ogr -s_srs EPSG:2193 -t_srs EPSG:2193 -f "GeoJSON"
doc-campsites-clipped.json doc-campsites.shp

I probably tried using the Ubuntu Software Centre.  I remember doing
something with FWTools, reluctantly, because it's out of date.  I remember
building lots of stuff from source.  I added the ubuntugis-unstable
repositry and did "apt-get update".  My hopes were raised when "apt-get
install gdal-bin" didn't fail, but then "apt-get install python-gdal"
responded with

The following packages have unmet dependencies:
 python-gdal : Depends: python (< 2.7) but 2.7.1-0ubuntu5 is to be installed
E: Broken packages

Which is how I ended up installing (maybe even building) earlier versions of

Many thanks,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/gdal-dev/attachments/20110924/36c4507f/attachment.html

More information about the gdal-dev mailing list