[gdal-dev] Error when importing/exporting to FileGDB

tim martin tjmgis at gmail.com
Wed Feb 22 08:51:12 EST 2012

Hi gdalers

I have installed OSGeo4W and have checked the ogr formats and see that
FileGDB is there.

So I then tested a simple ESRI shapefile using the following command

ogr2ogr -f "FileGDB" region.gdb region.shp

this worked and I can see the data in ArcMap.

I then tried a folder of shapefiles using

FOR %%A in (C:\data\*.shp) do (ogr2ogr -f FileGDB data.gdb %%A)

All worked well.

Now when I try to export from PostGIS or try to load data in using python I
get the following error

ERROR 1: Error: Failed at creating table for \Text (General Function

I then get errors for the other tables etc

I have done a search and found something about using -nlt POINT on gis
stack exchange, however that did not help.

There is also a post about stating the EPSG code, which I tried using
-a_srs EPSG:27700

Neither have helped and now a bit stuck,

Anyone else seen this error or know what is causing it


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/gdal-dev/attachments/20120222/d440e448/attachment.html

More information about the gdal-dev mailing list