[gdal-dev] ECW support on Fedora Linux - error

jkadlec jirikadlec2 at gmail.com
Fri Jul 27 07:33:40 PDT 2012

Hi, I have a problem making GDAL work with ECW files on Fedora Linux 17.
Here are the steps I did following the instructions on:
1. I downloaded, installed and compiled libecwj 3.3 library
2. I downloaded the source of gdal 1.9.1
3. I ran ./configure --with-ecw, make and make install
4. gdalinfo --formats now includes ECW
5. However, I have a problem opening any ECW file with GDAL. For example, I
downloaded the sample ECW files from 
http://www.terracolor.net/sample_imagery.html . One of the files is called
When I run gdalinfo Terracolor_SanFrancisco_US_15m.ecw I get a weird error:

terminate called after throwing an instance of 'std::length_error' what():
basic_string::_S_create Aborted (core dumped)

Other file types such as tiff or asc open with GDAL correctly.
Was anybody able to get GDAL running with ECW support on Linux?
Should I try to use the KAKADU library with GDAL instead of libecwj?

Any suggestions are welcome.

View this message in context: http://osgeo-org.1560.n6.nabble.com/ECW-support-on-Fedora-Linux-error-tp4991388.html
Sent from the GDAL - Dev mailing list archive at Nabble.com.

More information about the gdal-dev mailing list