[gdal-dev] Newby: Compile gdal with perl on Windows / deployment

Helmut Seidel M.A. info at knowhow-la.de
Tue Mar 5 09:40:47 PST 2013

Hello again,

I proceeded a little further now. I can run make generate and 
Makefile.PL now and dmake starts compiling until the error-message:

osr_wrap.cpp:1581:24: fatal error: cpl_string.h: No such file or directory
compilation terminated.
dmake.exe:  Error code 129, while making 'osr_wrap.o'

The file is there - but how do I include the path - I altered the 
path-variable and user the perl -I ... switch to the same result ...

Can anybody help?

Thanks Helmut

Am 01.03.2013 09:30, schrieb Helmut Seidel M.A.:
> Hello again,
> Thank you for your answers, which guided me through my first steps. 
> Yesterday I was quite happy to succeed compiling mapserver with perl 
> which is a first step. In compiling gdal I was not that lucky but got 
> a few millimeters forward.
> I tried compiling with MinGW and mysys - and the --with-perl option. 
> gdal itself compiles ok but the perl-portion breaks up with a file not 
> found error (perl.h). I guess MinGW gets confused with the perl 
> installations (it tries to use the one that comes with mysys not the 
> one I installed in C:\Perl. Is there a way how to tell configure/make 
> which Perl to use?
> I then tried the visualc option - which succeeded aswell, but without 
> perl. So here are two more questions (sorry for that):
>  1. Is it possibible to tell Visualc to compile with perl (as in the
>     --with-perl - option in MinGW)?
>  2. Is it possible to first build gdal without perl and then install
>     perl later?
> Thanks again.
> Helmut
> Am 27.02.2013 14:57, schrieb Helmut Seidel M.A.:
>> Hello everybody,
>> in my comming up perl-project I need to use the Geo::Gdal - module. 
>> As I understand I need to compile gdal from sources first and then 
>> build the perl bindings. So far so good, but as I'm not a C/C++ 
>> developer I ran into a host of problems. The first thing I tried, was 
>> to install MinGW and compile gdal with the "--with-perl" option, 
>> which ran for about two hours but broke of with a message complaining 
>> that perl 5.8 was not found on my system (I have ActivePerl 5.16 
>> installed) - as far as I could decipher the message - I tried gdal 
>> 1.90 and gdal 1.92.
>> I then tried to compile it using VC 10 which seemed to work but I 
>> didn't find a possibility where to put the "--with-perl" option - 
>> anyway I tried to compile perl using perl Makefile.PL which 
>> imediately complained about being not able to find gdal-conf (which I 
>> couldn't find either). I guess there would be lots of complaints 
>> after that, but I only got that far.
>> I'm sure my errors have something to do with setting up paths and 
>> compilation options, but I dont't know which and where to set them.
>> So here's my question: has anybody a blow by blow account for C/C++ 
>> dummies how to set up Geo::Gdal? That would be great!
>> Another question is how to deploy the finished application to other 
>> computers.
>> I hope you could understand all of my English and my questions are 
>> not too stupid - but I spend two working days on it so far so I'm a 
>> little desperate now.
>> Thanks and regards
>> _______________________________________________
>> gdal-dev mailing list
>> gdal-dev at lists.osgeo.org
>> http://lists.osgeo.org/mailman/listinfo/gdal-dev
> _______________________________________________
> gdal-dev mailing list
> gdal-dev at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/gdal-dev

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/gdal-dev/attachments/20130305/a072daac/attachment.html>

More information about the gdal-dev mailing list