[gdal-dev] Multithreading issue on pixel-based intensive access (GDAL 2.1.0)

Francisco Javier Calzado francisco.javier.calzado at ericsson.com
Fri Jul 29 04:30:49 PDT 2016

Thank you Even,

I maganed to compile properly in x86 today. I was setting WIN64 to NO, instead of just commenting it out. Maybe that was the culprit. 

Unfortunately, I still get the same error:

ERROR 7: Assertion `poNewest->poPrevious == NULL' failed
in file `c:\ericsson\3rdparties\gdal-2.1.0\gcore\gdalrasterblock.cpp', line 800

I have attached a simple code to reproduce it (Test.cpp). If you need the whole solution just ask me, although it is a very simple console test. I have also shared with you the zipped datasets through this link:
Just place them along with Test.exe file.

IMPORTANT: Bear in mind that these datasets come in a format still not supported officially by GDAL, as I am developing the driver. It is almost finished (just a few details pending) and fully working. Find the driver attached (Wizard_Driver.7z). 
By the way, what do we have to do to contribute with this new driver for GDAL?

Thank you so much Even.


-----Original Message-----
From: Even Rouault [mailto:even.rouault at spatialys.com] 
Sent: 28 July, 2016 17:42
To: Francisco Javier Calzado <francisco.javier.calzado at ericsson.com>
Cc: gdal-dev at lists.osgeo.org
Subject: Re: [gdal-dev] Multithreading issue on pixel-based intensive access (GDAL 2.1.0)

On Thursday 28 July 2016 13:11:13 Francisco Javier Calzado wrote:
> Thanks Even,
> I don't want to waste your time, so just before sending any code to be 
> tested I would like to be sure it is not a bug from my side. Although 
> I usually work with GDAL compiled in 64bits, I had to swap to x86 for 
> these tests. When trying to compile in 32bits with Visual Studio 2015 
> I got the following unresolved symbols:


Make sure the Visual Studio 32bit environment is properly set up. Check that
WIN64 from nmake.opt is let commented out.
Example of successful build:


Spatialys - Geospatial professional services http://www.spatialys.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Wizard_Driver.7z
Type: application/octet-stream
Size: 12935 bytes
Desc: Wizard_Driver.7z
URL: <http://lists.osgeo.org/pipermail/gdal-dev/attachments/20160729/99609554/attachment-0001.obj>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: Test.cpp
URL: <http://lists.osgeo.org/pipermail/gdal-dev/attachments/20160729/99609554/attachment-0001.ksh>

More information about the gdal-dev mailing list