[gdal-dev] Configuring GDAL 1.11.1 to use GEOS

William Kelly Magee William.Kelly.Magee at leidos.com
Wed May 18 14:23:00 PDT 2016


Thank you for the response.

Correct, I had not run "make install" on GEOS.  Since I am building GDAL 
without installing, I wanted to build GEOS the same.  This evidently 
results in GDAL not finding GEOS.  Running "make install" on GEOS, prior 
to building GDAL, correctly identifies GEOS support (confirmed GDAL 
configure output).

I am running into a second issue and not sure if anyone on the list has 
ever attempted this.  I am static linking libgdal.a to my app (no 
problem here) and am having difficulty static linking libgeos_c.a and 
libgeos.a.  I've tried copying the .a files to the working dir and have 
also tried using those in /usr/local/lib (put there by make install).  
Still get unresolved references.

I am assuming it is possible since static libraries for GEOS are 
created.  Do you know of any problems static linking?

Once again thanks!

- Kelly

On 05/18/2016 02:03 AM, Ari Jolma wrote:
> 18.05.2016, 00:57, William Kelly Magee kirjoitti:
>> Hello
>> I am trying to build GDAL with GEOS support on RHEL 6 (64-bit) and am 
>> getting nowhere fast!
>> I've been using the OGR api from gdal-1.11.1 for over a year with 
>> excellent results and now need to use the geometry methods that are 
>> only available with the inclusion of GEOS (else the message ERROR 6: 
>> GEOS support not enabled").
>> I've built geos-3.1.0 and the set the GDAL configure option 
>> "--with-geos" to point to "geos-config".  Initially this did not work 
>> as gdal configure was attempting to execute "geos-config" which did 
>> not have execute permission (doing a chmod 777 on "geos-config" 
>> resolved this).
>> GDAL builds fine and appears to partially recognize GEOS availability 
>> but cannot confirm "GEOSversion" in geos_c.  The following two lines 
>> are output from gdal configure;
>>         checking for GEOS version >= 3.1.0... yes
>>         checking for GEOSversion in -lgeos_c... no
>> At this point it looked like a search issue so I've updated the PATH 
>> and LIBRARY_PATH env vars to point to the geos "capri" directory 
>> containing "libgeos_c.la".  Still no luck.  Have tried copying 
>> libgeos_c.la to the gdal folder and /usr/local/lib but still no luck.
>> Going through the list I see where others have run across similar but 
>> not the same problem.
>> Does anyone have any suggestions on how to resolve this?
> Kelly,
> I've never come across problems like this with GEOS and GDAL. If GEOS 
> is in usual place (/usr/local/lib for example) GDAL configure picks it 
> up by default.
> It sounds a bit like you did not install GEOS. Did you issue "make 
> install" after building GEOS?
> Ari
>> Thanks,
>> Kelly
>> _______________________________________________
>> gdal-dev mailing list
>> gdal-dev at lists.osgeo.org
>> http://lists.osgeo.org/mailman/listinfo/gdal-dev
> N�n�r����)em�h�yhiם�w^��


*William Kelly Magee | Leidos*

*Senior Software Engineer | Maritime Solutions Division*

phone: 401.847.4210
_<mailto:william.kelly.magee at leidos.com>__william.kelly.magee at leidos.com 
<mailto:william.kelly.magee at leidos.com>_ | _leidos.com/natsec 

This email and any attachments to it are intended only for the 
identified recipients. It may contain proprietary or otherwise legally 
protect ed information of Leidos. Any unauthorized use or disclosure of 
this communication is strictly prohibited. If you have received this 
communic ation in error, please notify the sender and delete or 
otherwise destroy the email and all attachments immediately.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/gdal-dev/attachments/20160518/5feb98c7/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: image/gif
Size: 3947 bytes
Desc: not available
URL: <http://lists.osgeo.org/pipermail/gdal-dev/attachments/20160518/5feb98c7/attachment.gif>

More information about the gdal-dev mailing list