[gdal-dev] How to remedy GDAL_DATA not found?

sablok sablok at amazon.com
Thu Feb 9 14:55:45 PST 2017

So, here is what I am experiencing as of now :

postgresql# create extension postgis;
postgresql# select postgis_full_version();

the output returned by this command is :
POSTGIS="2.3.1 r15264" GEOS="3.5.0-CAPI-1.9.0 r4084" PROJ="Rel. 4.9.2, 08
September 2015" GDAL="GDAL 2.1.2, released 2016/10/24 *GDAL_DATA not found*"

where we see that postgis is not able to find the gdal directory which has
all the csv files it needs. So as a workaround I modified the gdal-config
binary which has CONFIG_DATA variable to point to the directory where gdal
is stored and restarted my postgres server after dropping the postgis
extension completely. But I still get the same result.

I don't want to add an environment variable per se, and looking for a way in
which it can be done by just modifying any file that postgis is referring to
while accessing gdal?

View this message in context: http://osgeo-org.1560.x6.nabble.com/How-to-remedy-GDAL-DATA-not-found-tp5307297.html
Sent from the GDAL - Dev mailing list archive at Nabble.com.

More information about the gdal-dev mailing list