[gdal-dev] Build PDFium with GDAL

Gane R gane.prog at gmail.com
Fri May 12 02:51:17 PDT 2017

Hi all,
I am trying to build GDAL with PDFium

I have used the link to get build script for linux

only change in standalone.gypi was removal of -fvisibility=hidden in
I got a GDAL build with pdfium build was success,
But gdalinfo for a Geospatial PDF crashes
at version gdal-2.2.0

Has anybody tried to build GDAL with PDFium recently, or there was a change
in the PDFium source ?
Gane R

On Wed, May 10, 2017 at 6:18 PM, Gane R <gane.prog at gmail.com> wrote:

> I got it working, I saw the post Handling pdfium build / integration and
> fixed it.
> On Tue, May 9, 2017 at 6:31 PM, Gane R <gane.prog at gmail.com> wrote:
>> Hi all,
>> I am trying to build GDAL with PDFium
>> I saw the link
>> https://github.com/rouault/pdfium/tree/build
>> I tried to use the linux script and the pdfium static lib to build. *pdfium
>> build succeed.*
>> I have few Questions:
>> Q1: I see some 3rdpary dependency for PDFium, I don't see those LICENSES
>> included, does overall including the 3rparty dependency, PDFium library
>> comes to point like similar to MIT license ?.
>> Q2. Can we do a cross compile with for PDFium, or any one tried.
>> Q3. Has any one got an error like this (error message follows in next few
>> lines) ? or I have gone wrong in build steps.
>> I started to build GDAL gdal-2.2.0 with pdfium
>> ./configure --with-pdfium=/home/pdfium/install
>> libtool: link: g++ .libs/gdalinfo_bin.o -o .libs/gdalinfo
>> /home/works/gdal_fresh/gdal-2.2.0/.libs/libgdal.so
>> -L/home/pdfium/install -L/home/pdfium/install/lib/pdfium -lpdfium
>> -lfpdfapi -lfpdftext -lformfiller -lpdfwindow -lfxedit -lfpdfdoc -lfxcodec
>> -lfx_libopenjpeg -lfx_lcms2 -lfx_libjpeg -lfx_zlib -lfdrm -lfxge -lfreetype
>> -lfx_agg -lfxcrt -lbigint -lz -lpthread -lrt -ldl
>> /usr/bin/ld: .libs/gdalinfo: hidden symbol `_ZN13CFDF_Document12CreateNewDocEv'
>> in /home/pdfium/install/lib/pdfium/libfpdfapi.a(fpdf_parser_fdf.o) is
>> referenced by DSO
>> /usr/bin/ld: final link failed: Bad value
>> collect2: error: ld returned 1 exit status
>> GNUmakefile:82: recipe for target 'gdalinfo' failed
>> make[1]: *** [gdalinfo] Error 1
>> make[1]: Leaving directory '/home/works/gdal_fresh/gdal-2.2.0/apps'
>> GNUmakefile:93: recipe for target 'apps-target' failed
>> make: *** [apps-target] Error 2
>> Thanks
>> Gane R
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/gdal-dev/attachments/20170512/b663a5a4/attachment.html>

More information about the gdal-dev mailing list