<div dir="ltr"><div><div><div><div><div><div>Hi all,<br></div>I am trying to build GDAL with PDFium<br><br>I have used the link to get build script for linux<br><a href="https://github.com/rouault/pdfium/tree/build" target="_blank">https://github.com/rouault/pdf<wbr>ium/tree/build</a><br><br></div><div>only change in standalone.gypi was removal of -fvisibility=hidden in standalone.gypi<br></div>I got a GDAL build with pdfium build was success, <br></div>But gdalinfo for a Geospatial PDF crashes <br></div>at version gdal-2.2.0<br><br></div>Has anybody tried to build GDAL with PDFium recently, or there was a change in the PDFium source ?<br></div>Gane R<br></div><div class="gmail_extra"><br><div class="gmail_quote">On Wed, May 10, 2017 at 6:18 PM, Gane R <span dir="ltr"><<a href="mailto:gane.prog@gmail.com" target="_blank">gane.prog@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr">I got it working, I saw the post Handling pdfium build / integration and fixed it.</div><div class="HOEnZb"><div class="h5"><div class="gmail_extra"><br><div class="gmail_quote">On Tue, May 9, 2017 at 6:31 PM, Gane R <span dir="ltr"><<a href="mailto:gane.prog@gmail.com" target="_blank">gane.prog@gmail.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div><div><div><div>Hi all,<br></div>I am trying to build GDAL with PDFium<br><br>I saw the link<br><a href="https://github.com/rouault/pdfium/tree/build" target="_blank">https://github.com/rouault/pdf<wbr>ium/tree/build</a><br><br>I tried to use the linux script and the pdfium static lib to build. <b>pdfium build succeed.</b> <br><br></div><div>I have few Questions:<br><br></div><div>Q1: I see some 3rdpary dependency for PDFium, I don't see those LICENSES included, does overall including the 3rparty dependency, PDFium library comes to point like similar to MIT license ?.<br><br></div><div>Q2. Can we do a cross compile with for PDFium, or any one tried.<br><br></div><div>Q3. Has any one got an error like this (error message follows in next few lines) ? or I have gone wrong in build steps.<br></div></div><br></div>I started to build GDAL gdal-2.2.0 with pdfium<br><div><br>./configure --with-pdfium=/home/pdfium/ins<wbr>tall<br><br>libtool: link: g++ .libs/gdalinfo_bin.o -o .libs/gdalinfo¬† /home/works/gdal_fresh/gdal-2.<wbr>2.0/.libs/libgdal.so -L/home/pdfium/install -L/home/pdfium/install/lib/pdf<wbr>ium -lpdfium -lfpdfapi -lfpdftext -lformfiller -lpdfwindow -lfxedit -lfpdfdoc -lfxcodec -lfx_libopenjpeg -lfx_lcms2 -lfx_libjpeg -lfx_zlib -lfdrm -lfxge -lfreetype -lfx_agg -lfxcrt -lbigint -lz -lpthread -lrt -ldl <br>/usr/bin/ld: .libs/gdalinfo: hidden symbol `_ZN13CFDF_Document12CreateNew<wbr>DocEv' in /home/pdfium/install/lib/pdfiu<wbr>m/libfpdfapi.a(fpdf_parser_<wbr>fdf.o) is referenced by DSO<br>/usr/bin/ld: final link failed: Bad value<br>collect2: error: ld returned 1 exit status<br>GNUmakefile:82: recipe for target 'gdalinfo' failed<br>make[1]: *** [gdalinfo] Error 1<br>make[1]: Leaving directory '/home/works/gdal_fresh/gdal-2<wbr>.2.0/apps'<br>GNUmakefile:93: recipe for target 'apps-target' failed<br>make: *** [apps-target] Error 2<br><br></div><div>Thanks<span class="m_-6512038043346391437HOEnZb"><font color="#888888"><br></font></span></div><span class="m_-6512038043346391437HOEnZb"><font color="#888888"><div>Gane R<br></div></font></span></div>
</blockquote></div><br></div>
</div></div></blockquote></div><br></div>