[GeoNode-devel] geonode: apache2 segmentation error on wgsi.py

Eugenio Trumpy frippe12573 at hotmail.com
Thu Oct 8 07:03:09 PDT 2015

Dear all,

I installed geonode version2.4.dev20151007120350.

Most of the facilities actually seems to work fine, the main problem I have is on maps.
I can create maps regularly, but I got a general 500 internal server error while I save
a map. 
Apache2 error log stated:

[Thu Oct 08 15:30:38.037330 2015] [core:error] [pid 10101] [client X.X.X.X:50787] End of script output before headers: wsgi.py, referer: http://my_server_name/maps/new
[Thu Oct 08 15:30:38.292052 2015] [core:notice] [pid 2697] AH00052: child pid 10004 exit signal Segmentation fault (11)

Actually both in django admin and geonode list of the map I see the last map 
I tried to save. However if I try to see the preview from the list of maps I got a page
IndexError at /maps/109
  list index out of range

In apache log I have:

[Thu Oct 08 15:52:20.829988 2015] [:error] [pid 10005] Internal Server Error: /maps/109
[Thu Oct 08 15:52:20.830287 2015] [:error] [pid 10005] Traceback (most recent call last):
[Thu Oct 08 15:52:20.830456 2015] [:error] [pid 10005]   File "/usr/local/lib/python2.7/dist-packages/django/core/handlers/base.py", line 112, in get_response
[Thu Oct 08 15:52:20.830628 2015] [:error] [pid 10005]     response = wrapped_callback(request, *callback_args, **callback_kwargs)
[Thu Oct 08 15:52:20.830768 2015] [:error] [pid 10005]   File "/dati/geonode/geonode/maps/views.py", line 112, in map_detail
[Thu Oct 08 15:52:20.830927 2015] [:error] [pid 10005]     config = map_obj.viewer_json(request.user)
[Thu Oct 08 15:52:20.831154 2015] [:error] [pid 10005]   File "/dati/geonode/geonode/utils.py", line 265, in viewer_json
[Thu Oct 08 15:52:20.831349 2015] [:error] [pid 10005]     str(int(keys[-1]) + 1)] = settings.MAP_BASELAYERS[0]['source']
[Thu Oct 08 15:52:20.831526 2015] [:error] [pid 10005] IndexError: list index out of range

Just to complete the description, I have no problem with the list of the layers, I can access each layers and use them on a new map.
Eventually, two days ago I installed geonode in ubuntu server 12.04 and I had this problem and others, so somebody in the user list suggested me 
to update the server OS version. Now I'm at 14.04. Yesterday when I did the dist-upgrade I had two hours of no error!!! Then I don't know (unfortunately) 
what 's happen and I started again to have the same error.

any hints on how to overcome this issue?

best regard


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20151008/c2b3818e/attachment-0001.html>

More information about the geonode-devel mailing list