[GeoNode-devel] Geonode Development to Production

Noel Jerome Borlongan njbborlongan.phillidar2.upd at gmail.com
Mon Sep 21 02:52:43 PDT 2015

Hi Geonode devs!

I installed Geonode for Development in my machine, but now we want Geonode
to be available to public, so what we did was migrate the virtual machine
containing the Geonode installation to a Proxmox VE. I followed the steps
discussed here:
Unfortunately, I cannot get pass setting localhost to Geonode webpage using
Apache2. Here is my geonode.conf:

*WSGIDaemonProcess geonode
user=www-data threads=15 processes=2*
*<VirtualHost *:80>*
*    ServerName localhost*
*    ServerAdmin webmaster at localhost*
*    DocumentRoot /home/borly/geonode/geonode*

*    ErrorLog /var/log/apache2/error.log*
*    LogLevel warn*
*    CustomLog /var/log/apache2/access.log combined*

*    WSGIProcessGroup geonode*
*    WSGIPassAuthorization On*
*    WSGIScriptAlias / /home/borly/geonode/geonode/wsgi.py*

*    <Directory "/home/borly/geonode/geonode/">*
*        Require all granted*
*        Options Indexes FollowSymLinks     *
*        IndexOptions FancyIndexing*
*    </Directory>*

*    Alias /static/ /home/borly/geonode/geonode/static/*
*    Alias /uploaded/ /home/borly/geonode/geonode/uploaded/*

*    <Proxy *>*
*        Require all granted*
*    </Proxy>*

*    ProxyPreserveHost On*
*    ProxyPass /geoserver http://localhost:8080/geoserver
*    ProxyPassReverse /geoserver http://localhost:8080/geoserver


When typing localhost in a web browser, an Internal Server Error occurs
which says:

*The server encountered an internal error or misconfiguration and was
unable to complete your request.*

*Please contact the server administrator at webmaster at localhost to inform
them of the time this error occurred, and the actions you performed just
before this error.*

*More information about this error may be available in the server error

I checked the Apache2 error log, and it says an *ImportError: No module
named django.core.wsgi*. I also tried editing wsgi.py (as suggested here:
by adding/appending the geonode path and virtualenv path to sys.path, but
still the same error occurs.

Thanks for the help!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20150921/6c6e54a8/attachment.html>

More information about the geonode-devel mailing list