[GeoNode-devel] Using GeoServer "Layer Group" within GeoNode?

Bruce Crevensten becrevensten at alaska.edu
Wed May 4 16:05:05 PDT 2016

Thanks for the tip, Simone!  Unfortunately, this didn't work for me.

I tracked down the code that looks to be responsible here, in the
`gsconfig` package, with (roughly) this call chain:

geonode/geoserver/management/commands/updatelayers.py ~ handle
geonode/geoserver/helpers ~ gs_slurp
~ get_resources

>From here, a few different calls are made, but none appear to directly
query the REST endpoint that returns layer groups.  I'm unsure if a layer
group should be a DataStore, a CoverageStore, or a WMS Store, but it
appears in none of those endpoints in my local instance:


...it does, however show up here:


I've tried a few variations on configuring the layer group to see if I
could coax it into one or the other category but couldn't get it to happen.

Version info: clean source install of GeoNode running on the 2.4.x branch;
GeoServer is 2.7.4.  Host OS is 14.04.02 LTS.

At this point, my questions are:

(1) Is this expected behavior?
(2) Is there a way to hack the GeoNode database to point at my layer group?
(3) If this is missing functionality, would it be of interest to the GN

If this is missing functionality, it's not clear to me how much existing
logic from the add/create layers code could be reused (it looks like the
URL endpoints for layers that the `gsconfig` library returns is rather
different from what you can get at the layergroups.xml endpoint).

Any further guidance would be appreciated!

- Bruce

On Sat, Apr 30, 2016 at 12:34 AM, Simone Dalmasso <simone.dalmasso at gmail.com
> wrote:

> Hi,
> Once you have created the layer group in geoserver you can run "geonode
> updatelayers " this should create the new layer in Geonode.
> Hope this helps
> Il sabato 30 aprile 2016, Bruce Crevensten <becrevensten at alaska.edu> ha
> scritto:
>> Is it possible to configure a layer in GeoNode that uses a "Layer Group"
>> that is created within GeoServer?  I'm trying to do something like this:
>> 1. Upload various layers in GeoNode,
>> 2. Compose a Layer Group in GeoServer from these layers, using the
>> GeoServer web interface,
>> 3. Create a new layer, or do something to make a new layer in GeoNode
>> display that Layer Group.
>> Step 3 is where I'm unclear what to do.  I tried a few variations of
>> using the Django admin interface to directly edit a Layer (and a MapLayer)
>> to attempt to point at the layer group, but wasn't successful.
>> Also, I saw that the documentation does discuss creating a layer group:
>> http://docs.geonode.org/en/master/tutorials/advanced/adv_data_mgmt/pretty_maps/base_map.html
>> ....but that tutorial continues to discuss uDig, not GeoNode.
>> Is this functionality supported?  If not, would this be something of
>> interest to others?
>> Thanks!
>> --
>> *Bruce Crevensten*
>> *Senior Software Engineer*
>> (SNAP) Scenarios Network for Alaska & Arctic Planning
>> www.snap.uaf.edu
> --
> Simone

*Bruce Crevensten*

*Senior Software Engineer*
(SNAP) Scenarios Network for Alaska & Arctic Planning
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20160504/c6034f5e/attachment.html>

More information about the geonode-devel mailing list