[GeoNode-devel] getting started

jonas ellehauge jonas at ellevator.net
Fri May 27 05:14:47 PDT 2016

Hi all,

I am just getting started with geonode and spent a few days wrapping my 
head around it. After some initial trouble, I got the production version 
up and running on a VirtualBox Ubuntu 14.04 server 64 bit. It appears 
that the production version is not suitable for customization, so I need 
a work-flow on how to customize the site before pushing it to production 

@GeoNode on twitter confirmed that there is a suitable work-flow for 
that and directed my to geonode-project 
<https://github.com/geonode/geonode-project> and ansible-geonode 
<https://github.com/GeoNode/ansible-geonode> and github which I have now 
spent another few days implementing - now finally admitting that I am 
stuck. @GeoNode also directed my to this email-list for further questions.

I ran "python manage.py syncdb" (why does it use sqllite by default with 
no postgis settings in my_geonode.settings?) and I ran "python manage.py 
runserver" only to see errors revealing that practically all html 
templates are missing from the my_geonode/temlates/. So, I copied all 
the templates from the production vm (at 
/usr/local/lib/python2.7/dist-packages/geonode/templates/*) to my host 
machine and put them in my_geonode/templates/ - only to see that all 
static css files etc are also missing.

Before I go ahead and copy those from the production vm, I need to know 
what I am doing wrong?

Why am I missing all these essential files when I follow the 
instructions on geonode-project 
<https://github.com/geonode/geonode-project> and based my project on the 
appropriate template?

The local geonode package is located at 
"my_geonode/venv/local/lib/python2.7/site-packages/geonode/" and doesn't 
contain any templates while the one on the procution vm does - why are 
those packages not identical - I assume they are both installed using 
pip? (I know the local one is while the vm one was installed indirectly 
with "apt-get install geonode").


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-devel/attachments/20160527/f768e9ea/attachment.html>

More information about the geonode-devel mailing list