[GeoNode-users] geonode no maps and layer

Eugenio Trumpy frippe12573 at hotmail.com
Thu Dec 3 07:32:38 PST 2015


that could be a solution.
However if I wanted to use the dev version can I use the db backup?

So the tasks would be: 1- dump DBs 2-update geonode and DBs 3-restore data in the DBs 4- syncdb and updatelayers

Is that correct?


From: simone.dalmasso at gmail.com
Date: Thu, 3 Dec 2015 16:03:22 +0100
Subject: Re: [GeoNode-users] geonode no maps and layer
To: frippe12573 at hotmail.com
CC: geonode-users at lists.osgeo.org

Hi Eugenio,
I think that you pulled from master, but on master we introduced new developments that involve metadata change. If you can't migrate the db by your own I suggest you to revert to the 2.4.0 tag.
2015-12-03 15:48 GMT+01:00 Eugenio Trumpy <frippe12573 at hotmail.com>:

Hi all,

today I controlled my geonode home page. It seemed to work fine, since the home page
showed 15 layers and 5 maps. However if I click on layers, any layers appears in the list.
The same happens form maps and documents.

I tried to launch updatelayers with any result.
The I re-sync the DB and updatelayers, but no results, only an error:

python manage.py updatelayers
Not enabling BingMaps base layer as a BING_API_KEY is not defined in local_settings.py file.
Stopping process because --ignore-errors was not set and an error was found.
Traceback (most recent call last):
  File "manage.py", line 28, in <module>
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 399, in execute_from_command_line
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/__init__.py", line 392, in execute
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/base.py", line 242, in run_from_argv
    self.execute(*args, **options.__dict__)
  File "/usr/local/lib/python2.7/dist-packages/django/core/management/base.py", line 285, in execute
    output = self.handle(*args, **options)
  File "/dati/geonode/geonode/geoserver/management/commands/updatelayers.py", line 108, in handle
  File "/dati/geonode/geonode/geoserver/helpers.py", line 458, in gs_slurp
    "bbox_y1": Decimal(resource.latlon_bbox[3])
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/manager.py", line 154, in get_or_create
    return self.get_queryset().get_or_create(**kwargs)
  File "/usr/local/lib/python2.7/dist-packages/modeltranslation/manager.py", line 341, in get_or_create
    return super(MultilingualQuerySet, self).get_or_create(**kwargs)
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/query.py", line 376, in get_or_create
    return self.get(**lookup), False
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/query.py", line 304, in get
    num = len(clone)
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/query.py", line 77, in __len__
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/query.py", line 857, in _fetch_all
    self._result_cache = list(self.iterator())
  File "/usr/local/lib/python2.7/dist-packages/polymorphic/query.py", line 264, in iterator
    for o in base_iter:
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/query.py", line 220, in iterator
    for row in compiler.results_iter():
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/sql/compiler.py", line 713, in results_iter
    for rows in self.execute_sql(MULTI):
  File "/usr/local/lib/python2.7/dist-packages/django/db/models/sql/compiler.py", line 786, in execute_sql
    cursor.execute(sql, params)
  File "/usr/local/lib/python2.7/dist-packages/django/db/backends/util.py", line 69, in execute
    return super(CursorDebugWrapper, self).execute(sql, params)
  File "/usr/local/lib/python2.7/dist-packages/django/db/backends/util.py", line 53, in execute
    return self.cursor.execute(sql, params)
  File "/usr/local/lib/python2.7/dist-packages/django/db/utils.py", line 99, in __exit__
    six.reraise(dj_exc_type, dj_exc_value, traceback)
  File "/usr/local/lib/python2.7/dist-packages/django/db/backends/util.py", line 53, in execute
    return self.cursor.execute(sql, params)
Exception: ('Failed to process reg2001_s_wgs84utm33', ProgrammingError('column base_resourcebase.metadata_uploaded_preserve does not exist\nLINE 1: ...ometry", "base_resourcebase"."metadata_uploaded", "base_reso...\n                                                             ^\n',))

Afterwords I updated also the geonode code from git, re-sync DB and updatelayer, but again the same error.
I checked the DB, the maps and layer are correctly described in the rows.

I think it is a connection problem between geonode and postgresql/postgis. Isn't it? If yes, how can I solve?

Thanks in advance



geonode-users mailing list

geonode-users at lists.osgeo.org


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20151203/1de0e675/attachment-0001.html>

More information about the geonode-users mailing list