[GeoNode-users] Cannot load geonode page: DoesNotExist: Site matching query does not exist. IntegrityError: Problem installing fixture

Shah Md. Rajibul Islam rajibul.islam at cdmp.org.bd
Sat Dec 12 21:29:26 PST 2015



I am using geonode 2.0 on Ubuntu 12.04 


I am having a problem while loading the geonode site as follows-

"There was a problem loading this page. Please contact your GeoNode
administrator (he may have received an email automatically if he configured
it properly). If you are the site administrator, enable debug mode to see
the actual error and fix it or file an issue in GeoNode's issue tracker"


It probably happened when I deleted the IP address from geoserver site
management and add a site name geonode.dmic.org.bd. However, I have added
the IP again to the site.


I tried to update the IP again using sudo geonode-updateip and
gives following error:

DoesNotExist: Site matching query does not exist.


When I run the sudo apt-get install --reinstall geonode command it gives
following error message:

IntegrityError: Problem installing fixture
es/geonode/layers/fixtures/initial_data.json': Could not load
jectRoleMapping(pk=3): duplicate key value violates unique constraint

DETAIL:  Key (subject, object_ct_id, object_id, role_id)=(anonymous, 42, 1,
4) already exists.


Is there any suggestions please?


Best regards



Shah Md. Rajibul Islam

GIS Analyst
Disaster Management & Relief Bhaban
92-93, Mohakhali C/A, Dhaka - 1212
Tel # 989 0937; 882 1255; 882 1459, Ext - 303
Mobile: +88 01716 027389, E-mail:  <mailto:rajibul.islam at cdmp.org.bd>
rajibul.islam at cdmp.org.bd
Web:  <http://www.cdmp.org.bd/> www.cdmp.org.bd


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20151213/53344200/attachment.html>

More information about the geonode-users mailing list