[GeoNode-users] Cannot load geonode page: DoesNotExist: Site matching query does not exist. IntegrityError: Problem installing fixture

Shah Md. Rajibul Islam rajibul.islam at cdmp.org.bd
Tue Dec 22 00:55:34 PST 2015

Dear Ariel,

Thank you for your reply and I am really sorry for late reply.

Is there other way to do the required task you mentioned? It would be better if I can do this using ssh client putty.

Looking forward to your reply.

Best regards

Sent from Samsung Mobile

-------- Original message --------
From: Ariel Nunez <ingenieroariel at gmail.com> 
Date: 12/14/2015  8:06 PM  (GMT+06:00) 
To: "Shah Md. Rajibul Islam" <rajibul.islam at cdmp.org.bd> 
Cc: geonode-users at lists.osgeo.org 
Subject: Re: [GeoNode-users] Cannot load geonode page: DoesNotExist: Site matching query does not exist. IntegrityError: Problem installing fixture 
Hello Rajib,

Since you deleted the default Site (with id=1) instead of editing the site name and url this caused problems with the permissions and all around the site.

Your best bet is to create a new Site object with id =1 and the right name and dome. Are you familiar with pgadminIII ? You can use that to connect to your database and recreate the missing entry in sites_site graphically.


On Sun, Dec 13, 2015 at 12:29 AM, Shah Md. Rajibul Islam <rajibul.islam at cdmp.org.bd> wrote:


I am using geonode 2.0 on Ubuntu 12.04 


I am having a problem while loading the geonode site as follows-

“There was a problem loading this page. Please contact your GeoNode administrator (he may have received an email automatically if he configured it properly). If you are the site administrator, enable debug mode to see the actual error and fix it or file an issue in GeoNode's issue tracker”


It probably happened when I deleted the IP address from geoserver site management and add a site name geonode.dmic.org.bd. However, I have added the IP again to the site.


I tried to update the IP again using sudo geonode-updateip and gives following error:

DoesNotExist: Site matching query does not exist.


When I run the sudo apt-get install --reinstall geonode command it gives following error message:

IntegrityError: Problem installing fixture '/usr/local/lib/python2.7/dist-packag                                                                                        es/geonode/layers/fixtures/initial_data.json': Could not load security.GenericOb                                                                                        jectRoleMapping(pk=3): duplicate key value violates unique constraint "security_                                                                                        genericobjectrolemap_subject_object_ct_id_object_i_key"

DETAIL:  Key (subject, object_ct_id, object_id, role_id)=(anonymous, 42, 1, 4) already exists.


Is there any suggestions please?


Best regards



Shah Md. Rajibul Islam

GIS Analyst
Disaster Management & Relief Bhaban
92-93, Mohakhali C/A, Dhaka - 1212
Tel # 989 0937; 882 1255; 882 1459, Ext - 303
Mobile: +88 01716 027389, E-mail: rajibul.islam at cdmp.org.bd
Web: www.cdmp.org.bd


geonode-users mailing list
geonode-users at lists.osgeo.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20151222/c42b0426/attachment-0001.html>

More information about the geonode-users mailing list