[GeoNode-users] geonode install in 12.04 in Docker fails

Ariel Nunez ingenieroariel at gmail.com
Wed Mar 4 08:40:22 PST 2015

Gavin, a few things:

1) There is no need to do "RUN paver setup", you can remove that line.

2) You only need to expose port 80 (Apache), there is a proxy for GeoServer
there at host:80/geoserver/

3) Can you run the first 3 commands via docker and then shell into the
docker machine and do the "apt-get install geonode" manually? That way we
get a better error that could give us a hint.

RUN apt-get -f -y install software-properties-common
RUN add-apt-repository -y ppa:geonode/testing
RUN apt-get update -y

4) After you have successfully installed GeoNode you need to create a
super user and then call geonode-updateip with the right url before
the instance is usable.

geonode createsuperuser
geonode-updateip <your ip>

Good luck,

On Wed, Mar 4, 2015 at 10:43 AM, Gavin Fleming <gavin at kartoza.com> wrote:

>  Hola Ariel
> On 04/03/2015 13:56, Ariel Nunez wrote:
> On Wed, Mar 4, 2015 at 6:49 AM, Gavin Fleming <gavin at kartoza.com> wrote:
>> invoke-rc.d: policy-rc.d denied execution of start.
>  Also, is this a fresh machine or an existing one?
> Docker (i.e. fresh)
>  The best way to go about getting started is to use Ubuntu 14.04 and
> GeoNode 2.4 beta (ppa:geonode/testing)
>  just tried that, getting the same error:
> https://gist.github.com/gubuntu/c18d657a27a7780a4c20
> Chao
> Gavin
> _______________________________________________
> geonode-users mailing list
> geonode-users at lists.osgeo.org
> http://lists.osgeo.org/cgi-bin/mailman/listinfo/geonode-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20150304/2f0c1211/attachment.html>

More information about the geonode-users mailing list