[GeoNode-users] segmentation fault while I save a map

Eugenio Trumpy frippe12573 at hotmail.com
Thu Oct 29 02:23:08 PDT 2015

Hi simone,

I tried this command (after the installation of ipdb):

ipdb manage.py runserver my_server_name:8000

and I got:
> /dati/geonode/manage.py(21)<module>()
---> 21 import os, sys


Can be an useful info?


From: simone.dalmasso at gmail.com
Date: Thu, 29 Oct 2015 09:44:04 +0100
Subject: Re: [GeoNode-users] segmentation fault while I save a map
To: frippe12573 at hotmail.com
CC: ingenieroariel at gmail.com; geonode-users at lists.osgeo.org

Eugenio, now that you are running with the dev server you should use ipdb to debug the content of MAP_BASELAYERS.
add "import ipdb; ipdb.set_trace()"
then do the operation that rises the error, the terminal will stop in that point and you'll be able to inspect all the variables.
my suspect is that the settings are not correct somehow.
2015-10-29 9:38 GMT+01:00 Eugenio Trumpy <frippe12573 at hotmail.com>:

Hi Ariel,

actually I sort out better the configuration file, and now I tested your command:

python manage.py runserver my_server_name:8000

on click on one map listed I got the following error lines:

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/django/core/handlers/base.py", line 112, in get_response
    response = wrapped_callback(request, *callback_args, **callback_kwargs)
  File "/dati/geonode/geonode/maps/views.py", line 112, in map_detail
    config = map_obj.viewer_json(request.user)
  File "/dati/geonode/geonode/utils.py", line 265, in viewer_json
    str(int(keys[-1]) + 1)] = settings.MAP_BASELAYERS[0]['source']
IndexError: list index out of range
[29/Oct/2015 03:21:18] "GET /maps/8 HTTP/1.1" 500 139436

Regarding the saving map operation currently I'm not able to test the operation in this mode, since I have a problem on login to django,
I have:
[29/Oct/2015 03:36:06] "POST /account/ajax_login HTTP/1.1" 400 32

hints on that?



From: frippe12573 at hotmail.com
To: ingenieroariel at gmail.com
CC: geonode-users at lists.osgeo.org
Subject: RE: [GeoNode-users] segmentation fault while I save a map
Date: Wed, 28 Oct 2015 18:04:58 +0100


I run the command you suggested me:

python manage.py runserver my_server_name:8000
Validating models...

0 errors found
October 28, 2015 - 12:03:02
Django version 1.6.11, using settings 'geonode.settings'
Starting development server at http://my_server_name:8000/
Quit the server with CONTROL-C.

then I tried to male the same operation, saving a new map, but I had not a traceback on the terminal.


From: ingenieroariel at gmail.com
Date: Wed, 28 Oct 2015 11:33:40 -0500
Subject: Re: [GeoNode-users] segmentation fault while I save a map
To: frippe12573 at hotmail.com
CC: geonode-users at lists.osgeo.org

Run the site with manage.py runserver (and fixe ip accordingly) and then try to save.
This time you would get a traceback on the terminal that mae be easier to debug.
On Wed, Oct 28, 2015 at 11:17 AM, Eugenio Trumpy <frippe12573 at hotmail.com> wrote:

Dear all,

unfortunately I am here again with the same problem I had 2 or 3 weeks ago.
The main problem is when I save a map I got a 500 server error, which is referred to the following line in the apache2 error log:

[Wed Oct 28 16:50:10.835817 2015] [core:notice] [pid 18289] AH00052: child pid 18734 exit signal Segmentation fault (11)

Actually the map is not saved, however it appears in the map list, without the thumb. 
If I click on such map I have the page error:

IndexError at /maps/6
  list index out of range

      Request Method:
      Request URL:

      Django Version:

      Exception Type:

      Exception Value:
      list index out of range

      Exception Location:
      /dati/geonode/geonode/utils.py in viewer_json, line 265

      Python Executable:
      Python Version:
      Python Path:
      Server time:
      Wed, 28 Oct 2015 10:50:54 -0500
As you suggested I tested an installation on vagrant box (ubuntu server 14.04, apache2.4.7, tomcat7 and postgresql9.3, all installed as packages). This test works fine, I had not the error on saving maps.

So I updated my server, now I have:
ubuntu 14.04, apache 2.4.7,  postgresql9.3+postgis2.1 installed as packages and tomcat7 installed manually.
After the syncdb problem (solved) I installed geonode.
Everything seems to work fine: I'm able to upload layers, I'm able to create the maps even choosing the layers uploaded, but I got again the same ewrror on saving maps.

Here I attached the local_setting.py file and the apache2 virtualhost config.
During the configuration I also follow the instructions regarding 'Configuring GeoServer' which is in the end, inserting the context param GEONODE_BASE_URL and the URL (my_server_name) in web.xml and I put my_server_name in the config.xml as indicated.

Actually, after many many attempt I'm giving up hope...

thanks for the possible hints



geonode-users mailing list

geonode-users at lists.osgeo.org




geonode-users mailing list

geonode-users at lists.osgeo.org


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/geonode-users/attachments/20151029/df576313/attachment.html>

More information about the geonode-users mailing list